Re: [Fwd: Re: librrds-perl]

From: Stefan Vunckx (bonkie_at_skynet.be)
Date: 02/17/04

  • Next message: Benedict Verheyen: "Re: [Q] apt-get/dpkg & pkg customization"
    To: debian-user@lists.debian.org
    Date: Tue, 17 Feb 2004 14:21:04 +0100
    
    

    On Tuesday 17 February 2004 13:55, Dave Howorth wrote:
    > Oops, forgot to send to the list ...
    >
    > Stefan Vunckx wrote:
    > > I want to install librdds-perl on my server but:
    > > "Sorry, but the following packages have unmet dependencies:
    > > librrds-perl: Depends: perlapi-5.6.1"
    >
    > Sounds like you're trying to install the package from stable.
    >
    > > I have perl-5.8.2 installed but this doesn't seem to provide a perlapi
    > > package ?? Anyone got a workaround for this ??
    >
    > Sounds like you have perl from testing or unstable installed.
    >
    > If both of these are true, you need to get your librrds-perl from the
    > same release you got your perl from.
    >
    > Cheers, Dave

    Mmm yes you are correct.

    Once again I was a bit too fast to ask questions instead of finding out for
    myself. Turns out I had commented the testing sources in sources.list and
    thus it found the same version for stable as for testing. Stupid stupid, it
    works now, thank you for pointing out my stupid mistake hehe.

    But I still have a question. Is there actually a safe way to downgrade a
    package (like say perl) without losing so many packages that depend on
    perl ?? Makes me want to think 3 times instead of the usual 2 before
    upgrading important packages ...

    Regards
    Stefan Vunckx

    -- 
    To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
    

  • Next message: Benedict Verheyen: "Re: [Q] apt-get/dpkg & pkg customization"