something weird happened to my cd-rw

From: xucaen (xucaen_at_access-4-free.com)
Date: 02/19/04

  • Next message: Wes Reneau: "using chroot to get packages needed for wireless card"
    Date: Thu, 19 Feb 2004 17:05:14 -0500
    To: Debian User <debian-user@lists.debian.org>
    
    

    Hi all, something weird happened to my cd-rw after upgrade.
    I upgraded to testing and installed the kernel-image-2.3.24-1-k6.
    I logged on, ran startx and then ran xcdroast. Everything seemed to be working.
    I put in a 650MB cd-r disk into my cd-rw drive and began to make a backup of some files.
    at about 98% I got a write error. hmm.. that seemed strange. I mounted the cd-r in my cd-rom drive
    but got an error saying no compatible filesystem. So, I popped the cd-r into my Windows PC and
    the disk seems fine. all of my files are there. So back over to debian I popped in another cd-r disk
    and... xcdroast says I have no cd-rw drive. It also can not detect my cd-rom drive. I did not reboot
    or anything before popping in the second cd-r disk. very strange. So I ran modconf thinking that
    the ide-scsi driver wasn't loaded anymore. The ide-scsi module was in fact loaded sSo I removed it
    and added it back. Then I added an append statement to my lilo.conf

    here is the image entry in my lilo.conf:

    default=Linux

    image=/vmlinuz
        label=Linux
        read-only
        initrd=/initrd.img
        append="hdc=scsi hdd=scsi"
    # restricted
    # alias=1

    I looked in /etc/modules.conf and there is no entry for ide-scsi.

    With the system the way it is right now I am able to mount both the cd-rom and the cd-rw from
    /dev/scd0 and /dev/scd1 respectively but I can not get xcdroast to detect the drives.

    cdrecord -scanbus gives me the following information:

    #begin cdrecord -scanbus
    Cdrecord-Clone 2.01a25 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
    NOTE: this version of cdrecord is an inofficial (modified) release of cdrecord
          and thus may have bugs that are not present in the original version.
          Please send bug reports and support requests to <cdrtools@packages.debian.org>.
          The original author should not be bothered with problems of this version.

    Linux sg driver version: 3.1.25
    Using libscg version 'schily-0.8'.
    scsibus0:
    cdrecord.mmap: Warning: controller returns wrong size for CD capabilities page.
            0,0,0 0) 'CD-ROM ' 'Drive/F5D ' '2.42' Removable CD-ROM
            0,1,0 1) 'LG ' 'CD-RW CED-8080B ' '1.09' Removable CD-ROM
            0,2,0 2) *
            0,3,0 3) *
            0,4,0 4) *
            0,5,0 5) *
            0,6,0 6) *
            0,7,0 7) *
    #end cdrecord -scanbus

    I also tried addiing this line to modules.conf but it seemed to have had no affect at all:

    options ide-cd ignore='hdc hdd'

    I even tried starting xcdroast with the -a option and also the -f option.

    I'm not sure what else to try. Strange that burning a cd worked that very first time.
    Does anyone have any ideas of what I should try next?

    thanks!!

    Jim

    -- 
    To UNSUBSCRIBE, email to debian-user-request@lists.debian.org 
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
    

  • Next message: Wes Reneau: "using chroot to get packages needed for wireless card"