hotplug, udev and usbkey question

From: Bob Alexander (bob_at_ngi.it)
Date: 03/10/05

  • Next message: Alexander Sack: "Re: Thunderbird segfaulting"
    Date: Thu, 10 Mar 2005 15:15:44 +0100
    To: Debian Users <debian-user@lists.debian.org>
    
    

    When I insert a USB memkey I do not get the /dev/usbkey device created.
    IIRC it did before one of the latest updates ...

    Can anyone direct me to what should be done in the rules to fix this ?

    Follows my syslog.

    TIA,
    Bob

    Mar 10 15:00:46 localhost usb.agent[6898]: usb-storage: loaded
    successfullyMar 10 15:00:46 localhost kernel: usb-storage: device found at 2
    Mar 10 15:00:46 localhost kernel: usb-storage: waiting for device to
    settle before scanning
    Mar 10 15:00:51 localhost kernel: Vendor: Model: USB Flash
    Memory Rev: 1.00
    Mar 10 15:00:51 localhost kernel: Type: Direct-Access
            ANSI SCSI revision: 00
    Mar 10 15:00:51 localhost kernel: usb-storage: device scan complete
    Mar 10 15:00:51 localhost scsi.agent[7018]: disk at
    /devices/pci0000:00/0000:00:1d.7/usb4/4-3/4-3:1.0/host0/target0:0:0/0:0:0:0
    Mar 10 15:00:52 localhost kernel: SCSI device sda: 246272 512-byte hdwr
    sectors
    (126 MB)
    Mar 10 15:00:52 localhost kernel: sda: assuming Write Enabled
    Mar 10 15:00:52 localhost kernel: sda: assuming drive cache: write through
    Mar 10 15:00:52 localhost kernel: SCSI device sda: 246272 512-byte hdwr
    sectors
    (126 MB)
    Mar 10 15:00:52 localhost kernel: sda: assuming Write Enabled
    Mar 10 15:00:52 localhost kernel: sda: assuming drive cache: write through
    Mar 10 15:00:52 localhost kernel: sda: sda1
    Mar 10 15:00:52 localhost kernel: Attached scsi removable disk sda at
    scsi0, channel 0, id 0, lun 0
    Mar 10 15:00:52 localhost udev[7047]: configured rule in
    '/etc/udev/rules.d/z_hal-plugdev.rules[2]' applied, 'sda' becomes '%k'
    Mar 10 15:00:52 localhost udev[7047]: creating device node '/dev/sda'
    Mar 10 15:00:52 localhost udev[7065]: configured rule in
    '/etc/udev/rules.d/z_hal-plugdev.rules[2]' applied, 'sda1' becomes '%k'
    Mar 10 15:00:52 localhost udev[7065]: creating device node '/dev/sda1'

    -- 
    To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
    

  • Next message: Alexander Sack: "Re: Thunderbird segfaulting"

    Relevant Pages

    • Re: Help with kernel configuration to add drivers
      ... > Do you have a formatted CF card in the reader? ... I would've guessed that the CF card had to be mounted ... format the drive sda using mkfs ... Oct 31 02:08:33 localhost kernel: usb 2-1: new full speed USB device ...
      (Fedora)
    • Re: how to access SD card via lexarmedia multi-card reader?
      ... Jun 25 14:03:03 localhost kernel: sda: assuming drive cache: write ... Jun 25 14:03:03 localhost kernel: Attached scsi removable disk sda at ...
      (Fedora)
    • Olympus C-1 Camera & Fedora 2
      ... Today I tryed to connect my digital camera to the fedora box... ... to sda and sda 1 and today the camera also is recognized, ... Oct 6 00:37:02 localhost kernel: usb 2-1: new full speed USB device ...
      (Fedora)
    • Re: hotplug, udev and usbkey question
      ... Mar 19 09:33:18 localhost kernel: Initializing USB Mass Storage driver... ... Mar 19 09:33:18 localhost kernel: usbcore: registered new driver usb-storage ... Mar 19 09:33:24 localhost kernel: sda: assuming drive cache: write through ...
      (Debian-User)
    • New 4G ipod, USB2, HFS+ and Linux
      ... Aug 2 22:53:10 localhost kernel: Vendor: Apple Model: iPod ... Aug 2 22:53:13 localhost kernel: sda: assuming Write Enabled ... Aug 2 22:53:13 localhost kernel: Buffer I/O error on device sda, ...
      (comp.os.linux.hardware)