sound doesn't work on sis 741 mboard

From: Jason Rennie (jrennie_at_csail.mit.edu)
Date: 03/26/05

  • Next message: Cyprian Laskowski: "DHCP suddenly no longer working"
    Date: Sat, 26 Mar 2005 09:25:35 -0500
    To: debian-user@lists.debian.org
    
    

    Hello,

    I just installed an SiS 741 motherboard and sound won't work. i.e. I
    get an error when I try to use ogg123 to play music files:

    jrennie@pinot:~/ogg$ ogg123 brand_x/unorthodox_behaviour/nuclear_burn.ogg

    Audio Device: OSS audio driver output

    Playing: brand_x/unorthodox_behaviour/nuclear_burn.ogg
    Ogg Vorbis stream: 2 channel, 44100 Hz
    Title: Nuclear Burn
    Artist: Brand X
    Genre: Jazz
    Date: 0
    Album: Unorthodox Behaviour
    Track number: 01
    libao - OSS cannot set rate to 44100
    Error: Cannot open device oss.

    Segmentation fault

    Debian seems to have recognized the sound card correctly as an
    i810-compatible. Here's the output of lsmod:

    jrennie@pinot:~$ lsmod
    Module Size Used by Tainted: PF
    ac97 3328 0 (unused)
    input 3872 0 (autoclean)
    openafs.mp 512664 2
    parport_pc 24424 1 (autoclean)
    lp 6916 0
    parport 27560 1 [parport_pc lp]
    af_packet 14408 1 (autoclean)
    printer 8096 0
    ehci-hcd 18892 0 (unused)
    usb-ohci 20136 0 (unused)
    usbcore 65996 1 [printer ehci-hcd usb-ohci]
    i810_audio 25916 0
    ac97_codec 13720 0 [i810_audio]
    soundcore 4420 2 [i810_audio]
    ide-scsi 10192 0
    scsi_mod 100788 1 [ide-scsi]
    sis900 14252 1
    crc32 2928 0 [sis900]
    ide-cd 31296 0
    cdrom 30112 0 [ide-cd]
    rtc 7112 0 (autoclean)
    ext3 68548 1 (autoclean)
    jbd 46104 1 (autoclean) [ext3]
    sis5513 11568 1 (autoclean)
    unix 16816 67 (autoclean)

    The sound card appears in the lspci listing and there don't appear to
    be any IRQ conflicts:

    jrennie@pinot:~$ sudo lspci -v
    0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (
    rev 03)
            Subsystem: Unknown device 1849:0741
            Flags: bus master, medium devsel, latency 0
            Memory at d0000000 (32-bit, non-prefetchable) [size=64M]
            Capabilities: [c0] AGP version 3.5

    0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS]: Unknown device 0003 (
    prog-if 00 [Normal decode])
            Flags: bus master, 66MHz, fast devsel, latency 32
            Bus: primary=00, secondary=01, subordinate=02, sec-latency=32
            I/O behind bridge: 0000b000-0000bfff
            Memory behind bridge: cfd00000-cfefffff
            Prefetchable memory behind bridge: bfa00000-cfbfffff

    0000:00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Br
    idge) (rev 25)
            Flags: bus master, medium devsel, latency 0

    0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (prog-if
     80 [Master])
            Subsystem: Unknown device 1849:5513
            Flags: bus master, medium devsel, latency 128
            I/O ports at ff00 [size=16]

    0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound
     Controller (rev a0)
            Subsystem: Unknown device 1849:7012
            Flags: bus master, medium devsel, latency 32, IRQ 18
            I/O ports at dc00 [size=256]
            I/O ports at d800 [size=128]
            Capabilities: [48] Power Management version 2

    0000:00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
     (rev 0f) (prog-if 10 [OHCI])
            Subsystem: Unknown device 1849:7001
            Flags: bus master, medium devsel, latency 32, IRQ 20
            Memory at cfff9000 (32-bit, non-prefetchable) [size=4K]

    0000:00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller
     (rev 0f) (prog-if 10 [OHCI])
            Subsystem: Unknown device 1849:7001
            Flags: bus master, medium devsel, latency 32, IRQ 21
            Memory at cfffa000 (32-bit, non-prefetchable) [size=4K]

    0000:00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
     (prog-if 20 [EHCI])
            Subsystem: Unknown device 1849:7002
            Flags: bus master, medium devsel, latency 32, IRQ 23
            Memory at cfffb000 (32-bit, non-prefetchable) [size=4K]
            Capabilities: [50] Power Management version 2

    0000:00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fa
    st Ethernet (rev 90)
            Subsystem: Unknown device 1849:0900
            Flags: bus master, medium devsel, latency 32, IRQ 19
            I/O ports at d400 [size=256]
            Memory at cfff8000 (32-bit, non-prefetchable) [size=4K]
            Expansion ROM at fffe0000 [disabled] [size=128K]
            Capabilities: [40] Power Management version 2

    0000:01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661FX/M
    661FX/M661MX/741/M741/760/M760 PCI/AGP (prog-if 00 [VGA])
            Subsystem: Unknown device 1849:6331
            Flags: 66MHz, medium devsel, IRQ 16
            BIST result: 00
            Memory at c0000000 (32-bit, prefetchable) [size=128M]
            Memory at cfee0000 (32-bit, non-prefetchable) [size=128K]
            I/O ports at bc00 [size=128]
            Capabilities: [40] Power Management version 2
            Capabilities: [50] AGP version 3.0

    Anyone have any ideas/suggestions as to what I should try? Any help
    is much appreciated.

    Thanks,

    Jason

    -- 
    To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
    with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
    

  • Next message: Cyprian Laskowski: "DHCP suddenly no longer working"

    Relevant Pages