Setting IP address not working

From: Alan Chandler (
Date: 06/14/05

  • Next message: Thomas Adam: "Re: Request for window manager recommendations"
    Date: Tue, 14 Jun 2005 14:44:23 +0100

    I am having a strange problem setting my ip address on my only (eth0)
    ethernet connection.

    If I use either a static or dhcp iface stanza in /etc/network/interfaces it

    Here is the output from the dhcp version.

    Internet Software Consortium DHCP Client 2.0pl5
    Copyright 1995, 1996, 1997, 1998, 1999 The Internet Software Consortium.
    All rights reserved.

    Please contribute if you find this software useful.
    For info, please visit

    sit0: unknown hardware address type 776
    sit0: unknown hardware address type 776
    Listening on LPF/eth0/00:50:da:cf:a5:06
    Sending on LPF/eth0/00:50:da:cf:a5:06
    Sending on Socket/fallback/fallback-net
    DHCPREQUEST on eth0 to port 67
    DHCPACK from
    SIOCSIFADDR: File exists
    bound to -- renewal in 10800 seconds.
    RTNETLINK answers: Cannot assign requested address


    What are the following?

    a) Reference to device sit0 - where did this come from
    b) What is this error message? "SIOCSIFADDR: File exists"
    c) RTNETLINK answers: Cannot assign requested address


    The ip address I end up with is (which I am guessing is some
    default in the device driver code).

    But I can't see what I am doing wrong. Any advice to get more info, or even
    to fix it?

    (I am running Debian Unstable)


    Alan Chandler

    To UNSUBSCRIBE, email to 
    with a subject of "unsubscribe". Trouble? Contact

  • Next message: Thomas Adam: "Re: Request for window manager recommendations"

    Relevant Pages

    • Re: How to set up wi-fi device?
      ... Can anyone share how they set up their card? ... is setup for dhcp, and for that reason I added some stuff to dhclient.conf. ... How is your eth0 setup? ... interface file above is only commented instructions to me. ...
    • Re: Help: configure networking
      ... Because this is an LTSP server, it will have a DHCP server in it. ... The router connects to the Edubuntu server on eth0, and the clients connect on eth1. ... This server is inside a Windows network serving DHCP that in turn connects to the internet. ...
    • Re: unable to bring up eth0
      ... hope this link will help with DHCP. ... >> iface lo inet loopback ... >> iface eth0 inet static ... > Are other DHCP-Clients in the same network running properly? ...
    • Re: Fwd: Billion 7800N
      ... need static network set up and then instruct on how to do DHCP. ... Ensure eth0 network device will be able to get an IP from the router ...
    • Re: Newbie problem - Ethernet card configuration
      ... > Looks like dhcpd is not installed. ... > # yum install dhcp ... and i am getting Broadcom set for eth0. ...