Re: k3b in etch?



Andreas Janssen wrote:
Hello

Chris Howie (<cdhowie@xxxxxxxxxxxxx>) wrote:

Joseph Smidt wrote:

It looks like k3b has been sitting in unstable never moving to
testing. Is k3b going to be in Etch or is Debian holding it back for
a reason?

k3b in unstable is compiled against the KDE 3.5 libs, and testing only
has 3.4.
You'll have to wait until 3.5 makes it to testing.


Or use k3b and libk3b2 0.12.10-1 from http://snapshot.debian.net, the
last versions from unstable build for KDE 3.4.

best regards
Andreas Janssen


Your post helped me get k3b in my testing machine! Thank you.

Here is what I did(after getting the two debs from the site you mentioned):
~# dpkg --install k3b_0.12.10-1_i386.deb libk3b2_0.12.10-1_i386.deb
~# apt-get -s install libflac++5
~# apt-get -f install


Details of the commonds output are:
~# dpkg --install k3b_0.12.10-1_i386.deb libk3b2_0.12.10-1_i386.deb
Selecting previously deselected package k3b.
(Reading database ... 267417 files and directories currently installed.)
Unpacking k3b (from k3b_0.12.10-1_i386.deb) ...
Selecting previously deselected package libk3b2.
Unpacking libk3b2 (from libk3b2_0.12.10-1_i386.deb) ...
dpkg: dependency problems prevent configuration of k3b:
k3b depends on libresmgr1; however:
Package libresmgr1 is not installed.
dpkg: error processing k3b (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libk3b2:
libk3b2 depends on libflac++5; however:
Package libflac++5 is not installed.
libk3b2 depends on libresmgr1; however:
Package libresmgr1 is not installed.
dpkg: error processing libk3b2 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
k3b
libk3b2

~# apt-get -s install libflac++5
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
k3b: Depends: libresmgr1 but it is not going to be installed
libk3b2: Depends: libresmgr1 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
specify a solution).

~# apt-get -f install
Reading package lists... Done
Building dependency tree... Done
Correcting dependencies... Done
The following extra packages will be installed:
libflac++5 libresmgr1
Recommended packages:
resmgr
The following NEW packages will be installed:
libflac++5 libresmgr1
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 48.3kB of archives.
After unpacking 176kB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://gulus.usherbrooke.ca testing/main libflac++5 1.1.2-3+b1
[41.1kB]
Get:2 http://gulus.usherbrooke.ca testing/main libresmgr1 1.0-3 [7204B]
Fetched 48.3kB in 0s (124kB/s)
Reading package fields... Done
Reading package status... Done
Retrieving bug reports... Done
Selecting previously deselected package libflac++5.
(Reading database ... 267669 files and directories currently installed.)
Unpacking libflac++5 (from .../libflac++5_1.1.2-3+b1_i386.deb) ...
Selecting previously deselected package libresmgr1.
Unpacking libresmgr1 (from .../libresmgr1_1.0-3_i386.deb) ...
Setting up libflac++5 (1.1.2-3+b1) ...
Setting up libresmgr1 (1.0-3) ...

Setting up libk3b2 (0.12.10-1) ...

Setting up k3b (0.12.10-1) ...



regards,
->HS


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx



Relevant Pages

  • Re: [SLE] APT & Reiserfs
    ... Try with apt-get -f install. ... This must resolve the unmet dependencies. ... This error message appears when apt is unable to locate a dependency in his ... > Reading Package Lists... ...
    (SuSE)
  • Re: Is there a UNIX standard for where to install local tools?
    ... tracking or dependency database. ... install them manually or install all without looking if he wants them. ... library and I did even prepare PAM package for Slackware. ... Too much scripting in any distribution tends to get in my way. ...
    (comp.unix.shell)
  • Re: Package dependency problems
    ... dpkg: dependency problems prevent configuration of libc6:i386: ... Package debconf is not installed. ... install anything. ...
    (Ubuntu)
  • Re: New Update has no kmod for new kernel and new nvidia driver
    ... custom yum plugin that would check the existence of an appropriate kmod ... package for every new kernel that is to be pulled in on an update, ... be a dependency of kmod-nvidia, and only users who install kmod-nvidia would ...
    (Fedora)
  • Re: Is there a UNIX standard for where to install local tools?
    ... First, you loose dependency tracking. ... Very old Red Hats with RPM package manager could encounter such problem. ... I realize most distributions install it. ... in the world out there more people use package managers ...
    (comp.unix.shell)