Re: "zope3" dependency problem



On Tue, Apr 11, 2006 at 09:09:04PM +0200, Piotr Chamera wrote:
Hello

I am beginner user of etch (testing) distribution.
Installation of "zope3" package causes installation
of python2.4 and python2.3. Can I rid off python2.3
somehow? I don't need it. Dependencies are as follow:

zope3 -> python2.4
-> python2.4-docutils -> python-docutils -> python -> python2.3

If you look at the dependencies for package "python"

apt-cache show python

you will see that it depends on python >= 2.3.5-1 so I'd guess you are
alright.

also, that package "python" is a "dependency" package which is basically
a meta-package to allow other packages to "depend" on python without
specifying the version.

the problem may be that if you attempt to remove python2.3 apt will try
to remove python and all the other packages that depend on it as well,
which could be ugly.

have you installed python2.4? I'd suggest you go ahead and install it
as it doesn't conflict with 2.3. Then try apt-get remove python2.3 and
see what it says, you can always say no to the removal.

A


Is it bug in distribution, or I'm wrong somewhere?

thanks
Piotr Chamera



--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact
listmaster@xxxxxxxxxxxxxxxx

Attachment: signature.asc
Description: Digital signature