XP and Samba.....again



Newbie here. I have a home network with a XP machine and a Debian
machine connected through a router. I have not set Static IP's on
either machine. I am trying to connect these machines with samba, and
I have made a simple smb.conf file as follows:

#######################################
[global]
# Server configuration paramaters
netbios name = LINUXBOX
server string = Samba %v on (%L)
workgroup = SANDSTORM
encrypt passwords = yes

[data]
path = /export/samba/data
comment = Data Drive
volume = Sample-drive
guest ok = yes

[test]
comment = TEsting
path = /export/samba/test
read only = no
guest ok = yes
####################################

Also from the command line I did

########################################
Linuxbox:/home/brent# smbpasswd brent
New SMB password:
Retype new SMB password:
Linuxbox:/home/brent# cat /etc/samba/smbpasswd
brent:1000:874EA23DF4AFD3CFC2265B23734E0DAC:153EDE431C871577C60F69CAD6DF1601:[U
]:LCT-45895F8A:
Linuxbox:/home/brent#
Linuxbox:/home/brent# ls -l /etc/samba/smbpasswd
-rw------- 1 root root 105 2006-12-20 10:06 /etc/samba/smbpasswd
##############################################

and an smbclient -U% -L localhost returns the following:

######################################
Linuxbox:/home/brent# smbclient -U% -L localhost
Domain=[SANDSTORM] OS=[Unix] Server=[Samba 3.0.14a-Debian]

Sharename Type Comment
--------- ---- -------
data Disk Data Drive
test Disk TEsting
IPC$ IPC IPC Service (Samba 3.0.14a-Debian on
(linuxbox))
ADMIN$ IPC IPC Service (Samba 3.0.14a-Debian on
(linuxbox))
lp Printer Generic dot-matrix printer entry
Domain=[SANDSTORM] OS=[Unix] Server=[Samba 3.0.14a-Debian]

Server Comment
--------- -------
BLACKBOX Black Computer
LINUXBOX Samba 3.0.14a-Debian

Workgroup Master
--------- -------
SANDSTORM BLACKBOX
###########################################

I can see LINUXBOX on the XP machine. When I double click on
"Linuxbox" on the XP machine it prompts me for a username and password.
I fill in the appropriate username and password hit enter, and it
prompts me again for the username and password except that in username
it has BLACKBOX\brent filled in (Blackbox is the name of the XP machine
and "brent" is the username). I am using the same username and
password for Samba, the Debian logon, and the XP logon.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx