RE: BAD Error Installing new Apache2 & PHP?



Andrew,

You may have forgotten this thread. Thanks for your previous
suggestions.

(BTW, your domain made me curious. Spokane, eh? I spent a very hot 4
days up there a few years ago attending a BMW motorcycle rally. From
what I see on the weather map, you're steamin' again!)

I'm currently running 'sarge' & am trying to upgrade to the latest in
sarge before upgrading to 'etch'. The problems I'm having doing this
make me reluctant to try & jump straight to etch before I get this
install worked out.

One thing that may have gotten my dependencies in a twist is that some
months ago I updated only libc6 in order to get the timezone updates for
the new DST settings. I've since read things saying that it's not a good
idea to upgrade the 'libs' pkgs separately. Who knew?

My most recent attempts are documented below. However, I really don't
get the convoluted dependencies. For instance, the line:
"libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22sarge5
is installed"

This means the pkg libc6-dev needs the "-sarge6" version of libc6, but
the "-sarge5" version is installed, right? But installing the newer
version of libc6 is what I'm trying to do. Is it only the conflict with
timezone folders? I'm wondering whether deleting (or temporarily moving)
the 'zoneinfo' directory would relieve the error when it tries to unpack
libc6_2.3.2.ds1-22sarge6_i386.deb.

Do I need to remove a package - libc6 or tzdata - to get past this? I
don't get what's hanging it up. I may have hosed things But... I don't
get how, why, or what to do about it :-(

Thanks for any help...
Ron

I've tried 'apt-get -u dist-upgrade' & get:
...
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.2.ds1-22sarge6) but 2.3.2.ds1-22sarge5
is installed
locales: Depends: glibc-2.3.2.ds1-22sarge6
E: Unmet dependencies. Try using -f.

Then tried 'apt-get -f install libc6' as well as 'aptitude install
libc6' -- still running into the same error msgs:
...........
Reading Package Lists... Done
Building Dependency Tree... Done
Suggested packages:
glibc-doc
The following packages will be upgraded:
libc6
1 upgraded, 0 newly installed, 0 to remove and 61 not upgraded.
2 not fully installed or removed.
Need to get 0B/4886kB of archives.
After unpacking 311kB disk space will be freed.
(Reading database ... 35942 files and directories currently installed.)
Preparing to replace libc6 2.3.2.ds1-22sarge5 (using

.../libc6_2.3.2.ds1-22sarge6_i386.deb) ...
Unpacking replacement libc6 ...
dpkg: error processing
/var/cache/apt/archives/libc6_2.3.2.ds1-22sarge6_i386.deb

(--unpack):
trying to overwrite `/usr/share/zoneinfo/Africa/Algiers', which is also
in

package tzdata
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.3.2.ds1-22sarge6_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
....................



Relevant Pages

  • install openssh-client and fixing broken dependencies
    ... Reading package lists... ... Reading state information... ... You might want to run 'apt-get -f install' to correct these. ... The following packages have unmet dependencies: ...
    (Ubuntu)
  • Re: Linux Vs. FreeBSD
    ... > the most widely used open source apps out there, ... > has made a lot of effort towards making it easy to install. ... > system of package management, toss it and get another one. ... since the binary dependencies certainly wouldn't be any ...
    (comp.os.linux.misc)
  • RE: Errors Upgrading to Latest sarge
    ... idea to upgrade the 'libs' pkgs separately. ... version of libc6 is what I'm trying to do. ... Do I need to remove a package - libc6 or tzdata - to get past this? ... You might want to run 'apt-get -f install' to correct these. ...
    (Debian-User)
  • RE: [SLE] Not So Fast: Linux on the Desktop
    ... > The problem with Linux is dependencies. ... > available from the SuSE disc or not and then install that package. ... One of the reasons why I like Linux, is because I can let a 6-year old ...
    (SuSE)
  • Re: Aptitude Error
    ... If there is a versioned dependency that can be satisfied from sid but not ... you will get the package from sid. ... It may have pulling in some dependencies from Sid, ... will install from testing and try to satisfy dependencies ...
    (Debian-User)