Re: Intel D201GLY2 MB with SiS audio controller - no sound



On Sunday 20 April 2008 08.53.03 LÉVAI Dániel wrote:
On Sat, 19 Apr 2008 23:31:42 you wrote:
I noticed the IRQ number in the second line -> IRQ 233. Isn't
this weird?

Not necessarily; what is your output for "cat /proc/interrupts"?

$ cat /proc/interrupts
CPU0
0: 26228 IO-APIC-edge timer
8: 1 IO-APIC-edge rtc
9: 0 IO-APIC-level acpi
14: 4377 IO-APIC-edge ide0
185: 34 IO-APIC-level ohci_hcd:usb1
193: 0 IO-APIC-level ohci_hcd:usb2
201: 0 IO-APIC-level ohci_hcd:usb3
209: 2 IO-APIC-level ehci_hcd:usb4
217: 139 IO-APIC-level eth0
225: 210 IO-APIC-level libata, eth1
NMI: 0
LOC: 26185
ERR: 0
MIS: 0

I am using Debian stable with linux kernel 2.6.18-6-686.

$ lspci

[...]

00:02.7 Multimedia audio controller: Silicon Integrated Systems
[SiS] AC'97 Sound Controller (rev a0)

Make sure that the module is unloaded (run "modprobe -r
snd-intel8x0" if necessary), then load it again and activate the
buggy_semaphore workaround:

modprobe snd-intel8x0 buggy_semaphore=1

Does that eliminate "semaphore is not ready" messages?

Yes, this eliminates them.
Now I get these error messages:

Apr 20 08:49:26 leva kernel: PCI: Enabling device 0000:00:02.7 (0000
-> 0001)
Apr 20 08:49:26 leva kernel: ACPI: PCI Interrupt 0000:00:02.7[C] ->
GSI 18 (level, low) -> IRQ 233
Apr 20 08:49:27 leva kernel: AC'97 0 does not respond - RESET
Apr 20 08:49:27 leva kernel: AC'97 0 access is not valid
[0xffffffff], removing mixer.
Apr 20 08:49:27 leva kernel: Unable to initialize codec #0
Apr 20 08:49:27 leva kernel: ACPI: PCI interrupt for device
0000:00:02.7 disabled
Apr 20 08:49:27 leva kernel: Intel ICH: probe of 0000:00:02.7 failed
with error -5

Thanks!

Daniel

It was a bad BIOS, after updating it works ok. Sorry for the noise.

Daniel

--
LÉVAI Dániel
GPG key ID = 0x4AC0A4B1
Key fingerprint = D037 03B9 C12D D338 4412 2D83 1373 917A 4AC0 A4B1



Relevant Pages

  • Re: Playing midi?
    ... try to modprobe snd_seq and snd_seq_midi. ... that udev had not created the appropriate node in /dev; ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • Re: Intel D201GLY2 MB with SiS audio controller - no sound
    ... 0: 26228 IO-APIC-edge timer ... then load it again and activate the buggy_semaphore ... Now I get these error messages: ...
    (Debian-User)
  • Sound problems
    ... modprobe w83627ehf ... mknod c /dev/dsp 14 3 ...
    (Fedora)
  • Re: Still learning about loading modules
    ... > I tried both David's and Andreas' suggestions. ... Modprobe gave a little different set of error messages but it ... Registered with The Linux Counter. ...
    (comp.os.linux.setup)
  • Re: Where to put modprobe for lmsensors?
    ... > I just installed lmsensors for on my RH 9 box. ... > modprobe i2c-nforce2 ... If they're error messages, you ... which case you can't get rid of them by redirecting stdout/stderr. ...
    (comp.os.linux.misc)