Re: Unable to upgrade NSLU2 running debian



Hi Bob,

I did in fact do apt-get update first, and have tried apt-get upgrade
as well and it fails with the same errors.
I usually try to update the nslu2 every month or so.

# cat /etc/apt/sources.list
# deb http://linux.csua.berkeley.edu/debian/ etch main

deb http://linux.csua.berkeley.edu/debian/ etch main
deb-src http://linux.csua.berkeley.edu/debian/ etch main

deb http://security.debian.org/ etch/updates main
deb-src http://security.debian.org/ etch/updates main


On Thu, Jan 15, 2009 at 01:22:48 -0800, Eric Higgins
(erichiggins@xxxxxxxxx) wrote:

I've noticed recently that I can no longer perform upgrades on my
Linksys NSLU2 running Debian ARM.
No luck from the debain-arm mailing list, they suggested I try this one.
Any help would be appreciated.

-Eric

# uname -a
Linux NSLUG 2.6.18-6-ixp4xx #1 Tue Feb 12 00:57:53 UTC 2008 armv5tel GNU/Linux

# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
The following NEW packages will be installed:
openssh-blacklist
The following packages will be upgraded:

[snip]

I saw your post on the other list but was unsure what your problem is.

Firstly, please confirm that you did an apt-get update before the
apt-get dist-upgrade and secondly post the contents of your
/etc/apt/sources.list file.

I am also wondering why a dist-upgrade rather than just an upgrade,
although I doubt if that is anything to do with your problem.

I run etch/arm on one NSLU2 and lenny/armel on another and upgrade both
with few problems so hopefully this is fixable.

That openssh-blacklist package dates back to last May. Presumably you
have not done an update/upgrade for a long time?

--
Bob Cox. Stoke Gifford, near Bristol, UK.
Please reply to the list only. Do NOT send copies directly to me.
Debian on the NSLU2: http://bobcox.com/slug/


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx