Re: X problem after upgrade--help!



[ Please wrap your lines at 80 characters or less for ordinary
discussion. ]

On Sun, May 17, 2009 at 08:29:42 -0700, Dr. Jennifer Nussbaum wrote:

Hi. I just upgraded from testing to unstable, in order to get some
updated packages I need.

X is now not working, and i dont know why. There are no useful
messages in /var/log/Xorg.0.log, that i can tell--no errors are
reported adn the only thing that looks bad is "SELinux: Disabled on
system, not enabling in X server".

There are no useful messages in /var/log/messages.

In /var/log/gdm/:0.log I get an error "RADEON(0): [dri]
RADEONDRIGetVersion failed to open the DRM" and then "[dri] Disabling
DRI."; but then perhaps better, "Unhandled monitor type 0 after
xf86InitialConfiguration" "Output LCD1 disable success". At the end of
this log there is "/usr/bin/X: symbol lookup error:
/usr/lib/xorg/modules/extensions//libdri.so: undefined symbol:
atiddxAbiDixLookupPrivate".

It looks like your X is trying to use libdri.so from the fglrx-driver
package together with the radeon driver; this cannot work. You either
have to make X use the fglrx driver (provided that you can install it
correctly) or you have to get rid of the fglrx-driver package (which
should restore the normal libdri.so from Xorg).

See also here:

http://bugs.debian.org/528800

--
Regards, | http://users.icfo.es/Florian.Kulzer
Florian |


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx