Re: problem compiling new kernel



bdebreil 写道:
Hi to Everyone,

With my old SARGE system, as stated here last week, I was unable to boot
newly compiled kernels, most likely because of the faulty initrd.img
that I got using 'mkinitrd'. For this reason, I decided to install
Lenny.

Now, with Lenny, I haven't so far been able to go any further in
recompiling usable kernels. 2.6.30.4 did compile without errors, but
then I found that I had no 'mkinitrd' on my new system. How am I to
generate an initrd.img ? I was unable to find any package that I could
install using apt-get with the name 'mkinitrd', there is no such thing
either in the cache base. However, when I installed Lenny (72 hours
ago), the install program did generate an initrd.img-2.6.26-2-686 that
is now installed in my /boot directory, and my /boot/grub/menu.lst file
does specify this file in the boot menu.

Thanks in advance for your help

P.S. I did find a doc about some related subjects in the /Documentation
directory of the downloaded kernel... but it was so old and obsolete
that it was useless, dated 1998 and mentioning only lilo, not grub...
this in a recent kernel doc (2008-2009) !


update-initramfs maybe the tool you are after.
Google it or man it.
It should be installed on your system. Or you can install it with initramfs-tools.
Good luck.


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx