Re: Problems with Debian PowerPC




On Dec 17, 2009, at 5:39 PM, Frans Pop wrote:

On Thursday 17 December 2009, Rick Thomas wrote:
It may not be "grave" for the installer (indeed, you've already
established at great length that it's not an installer problem at all)
but that doesn't make it any the less grave for whatever package it
does belong to. You've given me a few hints as to how to figure out
what package that might be. Any further help -- from anyone more
knowledgeable than I -- will be appreciated, of course.

This looks like a fairly likely reason:
http://packages.debian.org/squeeze/gnome-core

For some reason the package was forced to testing even though it was not
available on all architectures.

If that is the reason, then it means that Gnome is currently not
installable on all but 5 architectures. With powerpc probably the only one
very many people will really care about (though that's a steadily
declining number).

It's almost certain that both the relevant package maintainer and the
release team are already aware of this and that it has been a conscious
choice to accept the breakage. Whether or not it should block the release
of D-I is up to others.

How did I get there (I needed the roundabout way because I don't have a
powerpc box; it would have been trivial to check in aptitude)?

- http://edos.debian.net/edos-debcheck/
- choose squeeze -> in the most recent run, choose powerpc ->
http://edos.debian.net/edos-debcheck/results/testing/1261006803/powerpc/list.php

And notice that gnome-accessibility (and a few others, but that seems the
most likely cause) is listed, and check the reasons.

A new version of the package (1:2.28+3) has been built for all arches:
https://buildd.debian.org/~luk/status/package.php?p=meta-gnome2
But looks to be blocked by other packages for now:
http://release.debian.org/migration/testing.pl?package=meta-gnome2

Here, for the record, is the log of an attempt to do "aptitude full- upgrade" on my Debian Squeeze PowerPC test machine.

Here's the part that first indicates there might be trouble...

The following packages have unmet dependencies:
epiphany-extensions-more: Depends: epiphany-extensions (< 2.27) but 2.28.1-2 is to be installed.
epiphany-browser: Conflicts: epiphany-gecko but 2.29.3-1 is to be installed.
grdc: Depends: remmina which is a virtual package.
gnome: Depends: tomboy (>= 1.0) but it is not installable


Happy Solstice!

Rick


greybox:~# aptitude -Pv full-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
epiphany-browser epiphany-extensions-more gnome grdc
The following NEW packages will be installed:
gir1.0-clutter-0.8{a} gir1.0-freedesktop{a} gir1.0-glib-2.0{a} gir1.0-gstreamer-0.10{a} gir1.0-gtk-2.0{a}
gnome-disk-utility{a} gnome-js-common{a} libclutter-0.8-0{a} libclutter-cairo-0.8-0{a} libclutter-gtk-0.8-0{a}
libgdu-gtk0{a} libseed0{a}
The following packages will be REMOVED:
binfmt-support{u} cli-common{u} libart2.0-cil{u} libgconf2.0-cil{u} libglade2.0-cil{u} libglib2.0-cil{u}
libgmime-2.0-2a{u} libgmime2.2a-cil{u} libgnome-vfs2.0-cil{u} libgnome2.24-cil{u} libgnomepanel2.24-cil{u}
libgtk2.0-cil{u} libmono-addins-gui0.2-cil{u} libmono-addins0.2-cil{u} libmono-cairo2.0-cil{u} libmono-corlib2.0-cil{u}
libmono-i18n-west2.0-cil{u} libmono-posix2.0-cil{u} libmono-security2.0-cil{u} libmono-sharpzip2.84-cil{u}
libmono-system2.0-cil{u} libndesk-dbus-glib1.0-cil{u} libndesk-dbus1.0-cil{u} mono-2.0-gac{u} mono-gac{u} mono-runtime{u}
swfdec-mozilla{a} tomboy{u}
The following packages will be upgraded:
epiphany-browser-data epiphany-extensions epiphany-gecko gnome-accessibility gnome-core gnome-desktop-environment
gnome-office
9 packages upgraded, 13 newly installed, 28 to remove and 0 not upgraded.
Need to get 11.5MB of archives. After unpacking 17.7MB will be freed.
The following packages have unmet dependencies:
epiphany-extensions-more: Depends: epiphany-extensions (< 2.27) but 2.28.1-2 is to be installed.
epiphany-browser: Conflicts: epiphany-gecko but 2.29.3-1 is to be installed.
grdc: Depends: remmina which is a virtual package.
gnome: Depends: tomboy (>= 1.0) but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
epiphany-extensions-more
epiphany-gecko
gnome

Keep the following packages at their current version:
grdc [Not Installed]

Score is 266

Accept this solution? [Y/n/q/?] r gnome UNINST
Rejecting the removal of gnome
Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Keep the following packages at their current version:
epiphany-browser [2.26.3-2 (now)]
epiphany-browser-data [2.26.3-2 (now)]
epiphany-extensions [2.26.1-1 (now)]
epiphany-gecko [2.26.3-2 (now)]
gnome [1:2.26+0 (now)]
gnome-accessibility [1:2.26+0 (now)]
gnome-core [1:2.26+0 (now)]
gnome-desktop-environment [1:2.26+0 (now)]
gnome-office [1:2.26+0 (now)]
grdc [Not Installed]
swfdec-mozilla [0.8.2-1 (testing, unstable, now)]

Score is 580

Accept this solution? [Y/n/q/?] o
grdc depends upon remmina
-> Removing grdc

epiphany-browser conflicts with epiphany-gecko
-> Installing epiphany-browser 2.26.3-2 (now)

epiphany-gecko depends upon epiphany-browser (>= 2.28.0)
-> Installing epiphany-gecko 2.26.3-2 (now)

epiphany-gecko depends upon epiphany-browser-data (< 2.27)
-> Installing epiphany-browser-data 2.26.3-2 (now)

epiphany-extensions-more depends upon epiphany-extensions (< 2.27)
-> Installing epiphany-extensions 2.26.1-1 (now)

gnome depends upon tomboy (>= 1.0)
-> Installing gnome 1:2.26+0 (now)

gnome depends upon gnome-desktop-environment (= 1:2.26+0)
-> Installing gnome-desktop-environment 1:2.26+0 (now)

gnome depends upon swfdec-mozilla
-> Installing swfdec-mozilla 0.8.2-1 (testing, unstable, now)

gnome-desktop-environment depends upon gnome-core (= 1:2.26+0)
-> Installing gnome-core 1:2.26+0 (now)

gnome-accessibility depends upon gnome-core (>= 1:2.28+2~3squeeze1)
-> Installing gnome-accessibility 1:2.26+0 (now)

gnome-office depends upon gnome-core (>= 1:2.28+2~3squeeze1)
-> Installing gnome-office 1:2.26+0 (now)


Accept this solution? [Y/n/q/?] q
Abandoning all efforts to resolve these dependencies.
Abort.
greybox:~#

Relevant Pages

  • Cannot complete WMP11 setup...here is my log please help
    ... Package 'MPPRE' is version '10.0.0.3646'. ... Download complete. ... Installer: Preparing to set system restore point... ... Setup commandlines are "C:\Program Files\Windows Media ...
    (microsoft.public.windowsmedia)
  • Re: C00D2AFB ERROR CODE
    ... System Lang is 1033. ... Setup version 10.00.00.3646.] ... Package 'MYMUSIC' is version '0.0.0.7'. ... Installer: Preparing to set system restore point... ...
    (microsoft.public.windowsmedia.player)
  • Re: UNINSTALL WMP 10 TOTALLY
    ... It may be for several install attempts. ... Setup commandlines are "C:\Program Files\Windows Media ... Installer: Preparing to set system restore point... ... Package 'MPPRE' is version '10.0.0.3802'. ...
    (microsoft.public.windowsmedia.player)
  • Re: Connot install WMP 11
    ... Package 'MYMUSIC' is version '0.0.0.7'. ... Windows Media Player is currently running. ... Installer: Preparing to set system restore point... ... Package install complete. ...
    (microsoft.public.windowsmedia.player)
  • Connot install WMP 11
    ... Package 'MYMUSIC' is version '0.0.0.7'. ... Windows Media Player is currently running. ... Installer: Preparing to set system restore point... ... Package install complete. ...
    (microsoft.public.windowsmedia.player)