RE: Debian on a Dell r310?



Replying to my own post, for posterity: The machine didn't have a SAS 6/iR; I had that when I was originally configuring it for purchase, but a later quote used a PERC S300 instead, which is Windows-only. Swapping out the S300 for a 6/iR (which looks _exactly_ the same) fixed it, along with using one of the newer images at http://kmuto.jp/debian/d-i/ .


From: Justin Sherrill [mailto:Justin.Sherrill@xxxxxxxxxxxxxxxxxxxx]
Sent: Monday, June 07, 2010 4:58 PM
To: debian-user@xxxxxxxxxxxxxxxx
Subject: Debian on a Dell r310?

I have a Dell R310 server; The Debian Lenny installer does not see the CDROM or the hard drives.  The "testing" image does see the CDROM, but not the hard drives, which are SAS drives connected through a SAS 6/iR. 

I see mention of the SAS 6/iR as supported when searching, though I suspect it's the Dell thing of the same model name with slightly different chipsets.  In any case,  I assume there's a way to find a up-to-date driver for it, and then build an install CD with that support.

Can someone point me at:

A: a driver release that might support this?  (I think it would be megaraid_sas)
B: a document that describes how to build a custom installer with this newer code?

I'm willing to get there myself - I just need a signpost.

Justin C. Sherrill - American Rock Salt
p: 585-991-6825 f: 585-991-6926 c: 585-298-6826


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/B3CA3D5503F61C4892A60A1A230334591419C3EAF2@xxxxxxxxxxxxxxxxxxx