Re: Debian Sid questions on compiz, missing xorg.conf etc



On Mon, Sep 27, 2010 at 14:34, Shuanghe <tworiversfolk@xxxxxxxxx> wrote:
Hi, dear all Debian user,

I have a few questions regarding the Debian Sid installation, missing
xorg.conf and functionality of Compiz.

1. I installed a few days ago the Sid (using businesscard iso) in my Dell
Inspiron 9300 laptop. More or less everything seems OK. There're 2 problems
though that I can see immediately after the installation.

One thing is that my touchpad didn't work 100%. I mean I can move the mouse
point and the horizontal and vertical scroll bar work fine but I CANNOT use
"touch" for click. I had to click the 2 buttons below the touchpad for that.
It's not a big problem but it's annoying. Can anyone helps to solve this
problem?

This should help some:
http://wiki.debian.org/SynapticsTouchpad#Debiansqueeze.2Ckernel2.6.32-4andlater.2CXorg7.5


The other thing is that the installation didn't recognize my Windows OS.
Well, it did says during the installation that there's Windows OS on the
hard drive so I installed grub in MBR but grub didn't pick the windows up
when I rebooted the PC. I had to manually enable it after googling around..
Is this a bug? Anyway, I'm pretty new so I don't know how to report a bug
even if it is. So just a comment here.

Grub2 picked my Windows partition when I created it, so yes, that's a
regression.
Use the "reportbug" command: http://www.debian.org/Bugs/Reporting

2. I installed compiz compizconfig-settings-manager
compiz-fusion-plugins-main compiz-gnome compiz-gtk and some extra fusion
packages (and of course, the Nvidia drive). However when I open CCSM and
enabled some nice shiny animates it didn't work at all. there's compiz wiki
http://wiki.debian.org/Compiz saying you have to edit xorg.conf manually.
Until then I found out that I don't even have this file. Should I manually
write one? but how?

You generally don't need one anymore, but sometimes you need a partial
one to get certain things working. I don't have time ATM to go into it.

I tried to create a xorg.conf in /etc/X11 and copy+paste
the paragraph from that wiki, and then "compiz --replace " with and without
sudo, no luck. after rebooting, ooops, no gnome desktop anymore. after
deleting the file everything went back as before. But I really like some of
the compiz functions such as scale addons and Expo  for quick picking up the
windows. Any help here please?

I don't know much about Compiz, and I don't touch binary drivers (actually,
the Nouveau Open Source drivers might work for you, depends on your card),
so maybe someone else can help.

by the way, I installed nvidia-kernel-2.6.32-5-486, there's another with
name nvidia-kernel-2.6.32-5-686. No idea what's the difference.

*-486 means it was compiled to work even on a 486 (do any of the cards supported
by that driver even work in a 486?), *-686 means the compile included additional
optimizations for the 686 (MMX, SSE, etc).

Cheers,

Kelly Clowers


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/AANLkTi==nsq4uGWC3i=WK6eYmV=Ehg9haB05UE0egfeY@xxxxxxxxxxxxxx