Re: Upgrade from Lenny to Squeeze



Which version of postgresql were you running prior to the upgrade?

I presume 8.4 failed to configure as in order to use data from previous versions you need to upgrade the data via a dump/ restore or pgmigrator etc. Not sure what debians packages for postgres do/ attempt to do but I'm pretty sure the issue would be something to do with this.

--- On Tue, 16/11/10, Gary Roach <gary719_list1@xxxxxxxxxxx> wrote:

From: Gary Roach <gary719_list1@xxxxxxxxxxx>
Subject: Upgrade from Lenny to Squeeze
To: "Debian user mail list" <debian-user@xxxxxxxxxxxxxxxx>
Date: Tuesday, 16 November, 2010, 19:37
I have a dual boot Windows XP / Lenny
Toshiba Qosmio G25 laptop. I have it setup for dual boot
with XP on one hard drive and Linux on the other. I wanted
to upgrade to Squeeze. I ran an Aptitude upgrade by changing
Lenny to Squeeze in the /etc/apt/source.list file and then
running the usual update sequence. Everything worked except
Postgresql 8.4 refused to configure. After reading the bug
reports I concluded that this is a serious bug that isn't
going away soon. So I burned a Squeeze Network Installation
Disk (6.1 beta) and attempted to install the new system that
way. The Squeeze disk didn't recognize the windows system
and trashed my boot files. I finally did a fresh
installation using my old Lenny Network Installation Disk.
This corrected all of the problems but leaves me back where
I started.

Can anyone tell me how I can do this upgrade safely and
effectively.

Gary R.


-- To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/4CE2DD83.2040508@xxxxxxxxxxx







--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/644820.75261.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx