Re: Need help with post-squeeze problems



I figured it out. What happened was that there were a few packages that got
installed over the years, that were from testing or more likely unstable.
So, for instance, one package was dependent on g++-4.4.5-8, but 4.4.5-10 was
installed and this is what was gumming up things.

Now that that is resolved, I have one more question. There are a number of
kde3 3.5.9 and 3.5.10 packages that are listed as rc. I have trinity
installed, which is kde 3.5.12. If I dpkg -P the rc files, do I need to
apt-get install --reinstall the -trinity files to make sure it doesn't wipe
the needed config files or is the installer wise enough to know that there
is a package that needs them? This is mainly to clean up the package
listing...

--b

On Thu, Apr 28, 2011 at 1:30 PM, Sven Joachim <svenjoac@xxxxxx> wrote:

On 2011-04-28 18:39 +0200, Brad Alexander wrote:

I got my daughter's netbook upgraded to squeeze, however, there are some
issues that I have encountered. I did it per the squeeze release notes,
the
audit, etc, then apt-get update on the new sources.lists, apt-get
upgrade,
upgraded kernel and udev, rebooted, then did the dist-upgrade. The
dist-upgrade removed a bunch of packages:

The following packages will be REMOVED:
build-essential cervisia cupsddk-drivers debhelper dh-make g++ g++-4.3
gcc
gcc-4.3 gettext gnuift gnuift-perl imagemagick intltool-debian
kde-trinity
kdemultimedia-trinity kdewebdev-trinity kernel-package
kommander-trinity
libarts1-xine-trinity libblas3gf libcvsservice0 libdatrie0 libept0
libgfortran3 libgomp1 libgraphviz4 liblapack3gf libmagick10 librpm4.4
libstdc++6-4.3-dev libsuitesparse-3.1.0 libxine1 libxine1-misc-plugins
libxine1-plugins libxml-libxml-common-perl linux-headers-2.6.32-5-686
madwifi-source po-debconf python-glade2 python-gtk2 python-notify
python-numeric quanta-trinity wicd-gtk xserver-xorg-video-all
xserver-xorg-video-cyrix xserver-xorg-video-imstt
xserver-xorg-video-nsc
xserver-xorg-video-tseng xserver-xorg-video-v4l xserver-xorg-video-vga
xulrunner-1.9

This should not have happened. Are there some packages that you had put
on hold?

Now, when I try to install some of the packages that got removed, apt-get
does not want to reinstall the dependencies.

That's why they got removed in the first place, I suppose.

I'm not sure how far down the
rabbit hole I need to go.

With apt-get you can go as far as you like, it will never output any
useful diagnostics why it does not install the package you want.

Can someone tell me why the dependencies are not being installed and how
I
can fix this? I dom't necessarily want to reboot, at least until I get
her
wicd back.


[root@rubicon apt]# apt-get install wicd-gtk python-gtk2 python-glade2
python-numpy
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
python-numpy : Depends: libblas3gf but it is not going to be installed
or
libblas.so.3gf or
libatlas3gf-base but it is not going to be
installed
Depends: libgfortran3 (>= 4.3) but it is not going to be
installed
Depends: liblapack3gf but it is not going to be installed
or
liblapack.so.3gf or
libatlas3gf-base but it is not going to be
installed
E: Broken packages

Can someone tell me why the dependencies are not being installed and how
I
can fix this? I dom't necessarily want to reboot, at least until I get
her
wicd back.

Try using aptitude instead of apt-get, first in dry-run mode as a normal
user:

$ aptitude -s -V -D -o "Aptitude::Delete-Unused=false" install wicd-gtk

If the suggested solution does not suit you, press 'n' at the prompt and
see what else aptitude has to offer.

Sven


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact
listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/878vuuuvu6.fsf@xxxxxxxxxxxxx




Relevant Pages

  • Re: NetworkManager and XFCE for wireless support
    ... I also checked out the WiCD, but some of its dependencies where ... outside of packages for the stable realease and didn't know if there could be any problem in ... someone who knows about wireless can help. ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • Re: Downgrading Xorg
    ... source as well, due to dependencies? ... unstable version of Xorg on testing systems, and so I decided to do this ... The following packages will be REMOVED: ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • Re: F16->17 preupgrade - does it handle the /usr move?
    ... I clicked the Exit Installer button then hit Crtl-Alt-F2 to access the root shell. ... The theory here was that if the JBoss application server packages were removed, the upgrade process might skip this... ... # yum remove jboss* ... and faced a kernel panic. ...
    (Fedora)
  • Re: Newbie looking for a UNIX
    ... I see you have never administered a Debian system. ... But required on FreeBSD. ... upgrading Perl, you'll compile broken packages. ... Even that partially broken line-oriented installer I saw on ...
    (comp.unix.bsd.freebsd.misc)
  • Re: Installation of packages from backports, unstable and stable.
    ... I install the packages with the following command: ... |Subject: Debian GNU/Linux 5.0 updated ... |The Debian Installer has been updated in this point release to offer ... |Security Updates ...
    (Debian-User)