Re: X bother consoles



On Tue, 21 Jun 2011 15:37:21 +0200, maderios wrote:

On 06/21/2011 01:27 PM, Camaleón wrote:

I would be nice that you tell us what piece of hardware did you change.
I can guess it's the VGA card but it can be a fan or your sata dvd
recorder, who knows :-P

I changed everything (P8P67 motherboard, Intel CoreI7, ....) except
keyboard, mouse and screen

Oh... more items than I thought.

You mean that nouveau driver works fine?

It works fine with KMS, but it doesnt when KMS is disabled.

When you disabled KMS, what driver was loading the X server?

So let's recap.

You want to use nvidia closed driver and get it to work on terminal
consoles, right?

As you already have found the culprit (nvidia driver) and given that
this closed driver is completey up to nvidia, I would start by using
the most up-to-date version (275.09.07) and search in Google about
similar cases, like these, to find a possible workaround:

http://askubuntu.com/questions/45929/virtual-terminals-messed-up-with-proprietary-nvidia-graphics-driver

Giving a whirl to Xorg logs may also help.


As I said above, I tested also with a Matrox P690 PCIe (+vesa driver)

Why vesa? Matrox cards should have their own set of X drivers.

graphic card and I got exactly same display problem => the problem is
not with the nvidia driver

The problem can be present with both, vesa and nvidia.

Nothing useful at logs?

Greetings,

--
Camaleón


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/pan.2011.06.21.14.00.44@xxxxxxxxx