Re: nvidia-problems



On 08/10/11 15:53, Hans-J. Ullrich wrote:


Okay, let's back then to your very first thread and see what can be done,
taking in mind *your card is FX5700 Ultra* and not a GeForce 7300 GT
Ultra ;-)

Greetings,

I am so ashamed! It is just because on my work I build many used computers
with 7300GT, so this was in my head.

Well, to my problem: The legacy driver cannot be build, as it mourns the wrong
version. Please take a look:


protheus1:/usr/src/modules/nvidia-kernel-legacy-173xx# debian/rules binary-
modules
dh_prep
dh_quilt_patch
series-Datei vollständig angewandt, endet in Patch 2.6.36-ioctl.patch
/usr/bin/make LINUXDIR=/usr/src/linux
make[1]: Entering directory `/usr/src/modules/nvidia-kernel-legacy-173xx'
make -C /usr/src/linux M=`/bin/pwd` modules
make[2]: Entering directory `/usr/src/linux-headers-3.0.0-1-686-pae'
/usr/src/modules/nvidia-kernel-legacy-173xx/Makefile:162: *** Only 2.6.x and
later kernels are supported (3.0.0). Schluss.
make[4]: *** [_module_/usr/src/modules/nvidia-kernel-legacy-173xx] Fehler 2
make[3]: *** [sub-make] Fehler 2
make[2]: *** [all] Fehler 2
make[2]: Leaving directory `/usr/src/linux-headers-3.0.0-1-686-pae'
make[1]: *** [modules] Fehler 2
make[1]: Leaving directory `/usr/src/modules/nvidia-kernel-legacy-173xx'
make: *** [build-stamp] Fehler 2
protheus1:/usr/src/modules/nvidia-kernel-legacy-173xx#


----

I took a look in the "Makefile", and suppose, this is the problem:
# Check for kernel versions that we don't support.

BELOW26 := $(shell if [ $(VERSION) -lt 2 -o $(PATCHLEVEL) -lt 6 ]; then \
echo y; fi)

ifeq ($(BELOW26),y)
$(error Only 2.6.x and later kernels are supported \
($(VERSION).$(PATCHLEVEL).$(SUBLEVEL)))
endif

Maybe I could change this for fast testing? Or just commet this check out?
What do you think?

I think you are right. This test looks wrong to me for a 3.x kernel. Just comment it out for now.

It's failing because the PATCHLEVEL is 0 on 3.0. It should really be checking "if [ $(VERSION) -lt 2 -o ( $(VERSION) = 2 -a $(PATCHLEVEL) -lt 6 ) ]", although I'm unsure of the exact syntax.

--
Dom


--
To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx
Archive: http://lists.debian.org/4E906CC8.2010204@xxxxxxxxx



Relevant Pages

  • Re: nvidia-problems
    ... taking in mind *your card is FX5700 Ultra* and not a GeForce 7300 GT ... later kernels are supported. ... # Check for kernel versions that we don't support. ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • Legacy nvidia driver fails to compile with kernel 3.0.x (was: nvidia-problems)
    ... GT Ultra;-) ... and later kernels are supported. ... Check for kernel versions that we don't support. ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • hang with CONFIG_MCYRIXIII
    ... it seems down to compiling these later kernels with CONFIG_MCYRIXIII. ... This is free software; see the source for copying conditions. ... # Firmware Drivers ... # PCCARD support ...
    (Linux-Kernel)
  • Re: [2.6.26-rc4] mount.nfsv4/memory poisoning issues...
    ... corruption issues during NFS mount. ... Have you seen the problem on client kernels earlier than 2.6.25? ... # Device Drivers ... # SCSI support type ...
    (Linux-Kernel)
  • long-term regression
    ... I haven't had time to bisect this, but I'm having a problem on a AMD64 gentoo system where the printer doesn't work with recent kernels. ... dmesg appears to show the port being detected, but writes to the port under newer kernels appear to complete, but no data gets to the printer. ... # ACPI Support ... # Device Drivers ...
    (Linux-Kernel)