Re: Upgrading to Iceweasel 10 in Squeeze

On Fri, Feb 03, 2012 at 02:18:31PM +1100, Scott Ferguson wrote:
On 03/02/12 13:32, Tony Baldwin wrote:
On Fri, Feb 03, 2012 at 11:41:45AM +1100, Rob Hurle wrote:
Thanks for this:

On 2 February 2012 19:17, Scott Ferguson
<> wrote:
In case people don't subscribe to pkg-mozilla-maintainers (and for those
the do search this list before posting)

# dpkg -i libvpx0_0.9.7.p1-2_i386.deb; apt-get install xulrunner-10.0

At this point, II get:

The following packages have unmet dependencies:
xulrunner-10.0 : Depends: libnss3-1d (>= 3.13.1) but
3.12.8-1+squeeze4 is to be installed
E: Broken packages>

I have backports enabled, and my iceweasel was updated to 10.0
yesterday when I did a standard safe-upgrade.

Perhaps this is a function of adding
deb squeeze-backports iceweasel-release
to your /etc/apt/sources.list


I suspect you may have Wheezy/Sid/Experimental and/or Multimedia enabled.

Where did you get libnss3-1d_3.13.1.with.ckbi.1.88-1~bpo60+1_i386.deb
from if not from:- squeeze-backports main

Here's my sources.list:

deb squeeze main non-free contrib
deb-src squeeze main non-free contrib
deb squeeze-backports iceweasel-release
deb squeeze main
deb stable main
deb stable non-free main
deb squeeze-backports main
non-free contrib experimental
deb squeeze experimental main
deb squeeze-proposed-updates non-free
contrib main experimental
deb squeeze/updates non-free contrib main
deb squeeze main

all tony, all the time!

To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx