Problems with flashplayer on a new installation of Squeeze.

Is there a solution to the following problem? (See below) I see that the bug
was reported two years ago, so I am tempted to go for purge, but that may
leave some detritus. :-(

And if I were to purge flashplugin-nonfree, what could I install that would
actually work to play flash?

Would I do better to scrap, what is a very new installation of Squeeze - this
was part of the installation process - and reinstall?


root@Squeeze:/home/john# aptitude install flashplugin-nonfree
The following NEW packages will be installed:
0 packages upgraded, 1 newly installed, 0 to remove and 8 not upgraded.
Need to get 17.9 kB of archives. After unpacking 135 kB will be used.
Get:1 squeeze/contrib
flashplugin-nonfree amd64 1:2.8.2 [17.9 kB]
Fetched 17.9 kB in 0s (50.4 kB/s)
Selecting previously deselected package flashplugin-nonfree.
(Reading database ... 136074 files and directories currently installed.)
Unpacking flashplugin-nonfree (from
.../flashplugin-nonfree_1%3a2.8.2_amd64.deb) ...
Processing triggers for man-db ...
Setting up flashplugin-nonfree (1:2.8.2) ...
ERROR: wget failed to download

To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx
with a subject of "unsubscribe". Trouble? Contact listmaster@xxxxxxxxxxxxxxxx