Re: nvidia driver works w/ new kernel and inittab 3, but not 5

From: Alexander Dalloz (alexander.dalloz_at_uni-bielefeld.de)
Date: 04/17/04

  • Next message: Alexander Dalloz: "Re: happy to write How to's on PPPoE.......:)"
    Date: Sat, 17 Apr 2004 17:04:01 +0200
    To: For users of Fedora Core releases <fedora-list@redhat.com>
    
    
    
    

    Am Sa, den 17.04.2004 schrieb Clint Harshaw um 15:17:

    > I wasn't successful :-(

    sad

    > However, I have new information to report. I am able to get the driver
    > to work immediately after compiling it with the 2179 kernel by startx in
    > run level 3. But when I reboot -- whether I am in run level 3 or 5 --
    > the error message below appears:
    >
    > nvidia.o module for 2.4.22-1.2179.nptl not found
    > Disabling nvidia driver
    >
    > I now look back at my original post, and believe that my description of
    > the symptoms was not complete. I was starting X immediately after the
    > compiling of the driver, and the nvidia driver worked. While I was in X,
    > I changed the run level to 5 and would reboot, only to see the nvidia
    > driver not work. In other words, I do not believe I ever tested a
    > *reboot* in run level 3!! I believe my current situation is a more
    > accurate and complete description of the symptoms:

    Please, be more careful with your descriptions. The sentence "a *reboot*
    in run level 3" makes no sense. Do not mix things. It does not matter
    whether you start a reboot in runlevel 1 or 3 or 5, nor whether it will
    automatically reboot into 1 or 3 or 5.

    > - nvidia driver works in 2179 when starting X immediately after
    > compiling the driver following artoo's instructions exactly.
    > - nvidia.o module for the 2179 kernel isn't available when I'm booting,
    > thus the driver isn't starting when X starts, no matter whether I am in
    > run level 3 or 5.

    Unfortunately you did less to find out the cause of the problem. It is
    no effort to blame you! Seeing the situation you describe you will have
    to ask yourself: what might be the reason that directly after the driver
    compilation it is loaded running kernel .2179 while after a reboot the
    system does not find the nvidia.o module. That is the point and not
    whether rebooting to runlevel 3 or 5.

    So lets gather some data. I suggest you do the following tasks to
    discover what's going wrong.

    1) Compile the NVidia driver. It will be loaded then. Find out where it
    is by running "find /lib/modules -name nvidia.o". It should be
    "/lib/modules/2.4.22-1.2179.nptl/kernel/drivers/video/nvidia.o". If the
    module is not in the kernel module's directory you see already the
    reason for the failure.
    Then check all nvidia.o modules the find run printed out for their
    dates. One of them must have the current date. Will it be compiled for
    the old .2174 kernel? Then follow the advise to uninstall the old kernel
    source.
    Check also that /etc/modules.conf contains a line "alias char-major-195
    nvidia".

    > and
    >
    > - nvidia driver and module work fine when booting into 2174.

    > Clint

    Alexander

    -- 
    Alexander Dalloz | Enger, Germany | GPG key 1024D/ED695653 1999-07-13
    Fedora GNU/Linux Core 1 (Yarrow) on Athlon CPU kernel 2.4.22-1.2179.nptl
    Sirendipity 16:44:35 up 1 day, 20:33, load average: 0.10, 0.05, 0.01 
                       [ Γνωθι σ'αυτον - gnothi seauton ]
                 my life is a planetarium - and you are the stars
    
    

    
    

    -- 
    fedora-list mailing list
    fedora-list@redhat.com
    To unsubscribe: http://www.redhat.com/mailman/listinfo/fedora-list
    


  • Next message: Alexander Dalloz: "Re: happy to write How to's on PPPoE.......:)"