Re: system console redirection - all but boot messages redirected ttyS0?



On 24/11/11 18:27, Chris Adams wrote:
Once upon a time, Morgan Read <mstuff@xxxxxxxxxxx> said:
Thanks for getting back - I followed your instructions. It seemed I
needed to swap console=ttyS0 and console=tty0 BUT opposite from what you
suggested. That is, console=ttyS0 was last and by swapping it with
console=tty0 and making console=ttyS0 listed first I had rc script
(userspace) messages reported to ttyS0... Strange?

Stranger still, when I did the above, I stopped getting a login prompt
on ttyS0. So, swapping as I said above (opposite to your suggestion)
gave me rc script messages to ttyS0 and no login...

Do you have any ideas how to get the login prompt back?

It is a bug in plymouth (which provides the graphical boot animations).
You can add "rd_NO_PLYMOUTH" to your boot line (as long as you don't
have encrypted filesystems) and the serial console should work as
expected (with console=ttyS0 listed after console=tty0).

I think it is fixed in newer plymouth, but I'm not sure. I see the bug
on RHEL 6 systems, and the fix has not been released there yet.

Ah, of course I should have searched bugzilla...
Is this the bug here:
https://bugzilla.redhat.com/show_bug.cgi?id=691374#c4
?

Many thanks,
M.


--
Morgan Read
NEW ZEALAND
<mailto:mstuffATreadDOTorgDOTnz>

Confused about DRM?
Get all the info you need at:
http://drm.info/
--
users mailing list
users@xxxxxxxxxxxxxxxxxxxxxxx
To unsubscribe or change subscription options:
https://admin.fedoraproject.org/mailman/listinfo/users
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org