Error building GNOME using JHBuild



Hi,

I am running Fedora 12 64 bit OS and trying to build GNOME 2.30.0
moduleset using JHBuild.

Below are the errors I am getting during build. Some of the packages
required are not available in Fedora 12.
Please help me to resolve these issues.


c++ -o nsNSSCallbacks.o -c -I../../../../dist/include/system_wrappers
-include ../../../../config/gcc_hidden.h -DNSS_ENABLE_ECC
-DXPCOM_TRANSLATE_NSGM_ENTRY_POINT=1 -DMOZILLA_INTERNAL_API
-D_IMPL_NS_COM -DEXPORT_XPT_API -DEXPORT_XPTC_API
-D_IMPL_NS_COM_OBSOLETE -D_IMPL_NS_GFX -D_IMPL_NS_WIDGET -DIMPL_XREAPI
-DIMPL_NS_NET -DIMPL_THEBES -DOSTYPE=\"Linux2.6.32.11-99.fc12\"
-DOSARCH=Linux -I/src/gnome/install/include/nss -I. -I.
-I../../../../dist/include/nspr -I../../../../dist/include/xpcom
-I../../../../dist/include/string -I../../../../dist/include/necko
-I../../../../dist/include/uriloader -I../../../../dist/include/pref
-I../../../../dist/include/docshell -I../../../../dist/include/caps
-I../../../../dist/include/dom -I../../../../dist/include/intl
-I../../../../dist/include/locale -I../../../../dist/include/profile
-I../../../../dist/include/windowwatcher -I../../../../dist/include/js
-I../../../../dist/include/widget -I../../../../dist/include/layout
-I../../../../dist/include/content
-I../../../../dist/include/xpconnect
-I../../../../dist/include/unicharutil
-I../../../../dist/include/pipboot -I../../../../dist/include
-I../../../../dist/include/pipnss -I/src/gnome/install/include/nspr
-I../../../../dist/sdk/include -fPIC -fno-rtti -fno-exceptions
-Wall -Wconversion -Wpointer-arith -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wcast-align
-Wno-long-long -pedantic -fno-strict-aliasing -fshort-wchar -pthread
-pipe -DNDEBUG -DTRIMMED -O2 -DMOZILLA_CLIENT -include
../../../../mozilla-config.h -Wp,-MD,.deps/nsNSSCallbacks.pp
nsNSSCallbacks.cpp
nsNSSCallbacks.cpp: In member function ‘virtual nsresult
nsHTTPListener::OnStreamComplete(nsIStreamLoader*, nsISupports*,
nsresult, PRUint32, const PRUint8*)’:
nsNSSCallbacks.cpp:671: warning: conversion to ‘PRUint16’ from
‘unsigned int’ may alter its value
nsNSSCallbacks.cpp: At global scope:
nsNSSCallbacks.cpp:1118: error: ‘CERT_StringFromCertFcn’ does not name a type
nsNSSCallbacks.cpp: In function ‘char*
MyAlternateOCSPAIAInfoCallback(CERTCertificate*)’:
nsNSSCallbacks.cpp:1144: error: ‘oldOCSPAIAInfoCallback’ was not
declared in this scope
nsNSSCallbacks.cpp: In function ‘SECStatus RegisterMyOCSPAIAInfoCallback()’:
nsNSSCallbacks.cpp:1189: error: ‘oldOCSPAIAInfoCallback’ was not
declared in this scope
nsNSSCallbacks.cpp:1189: error:
‘CERT_RegisterAlternateOCSPAIAInfoCallBack’ was not declared in this
scope
nsNSSCallbacks.cpp: In function ‘SECStatus UnregisterMyOCSPAIAInfoCallback()’:
nsNSSCallbacks.cpp:1208: error: ‘oldOCSPAIAInfoCallback’ was not
declared in this scope
nsNSSCallbacks.cpp:1209: error:
‘CERT_RegisterAlternateOCSPAIAInfoCallBack’ was not declared in this
scope
gmake[5]: *** [nsNSSCallbacks.o] Error 1
gmake[5]: Leaving directory `/src/gnome/source/mozilla/security/manager/ssl/src'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/src/gnome/source/mozilla/security/manager/ssl'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/src/gnome/source/mozilla/security/manager'
gmake[2]: *** [libs_tier_toolkit] Error 2
gmake[2]: Leaving directory `/src/gnome/source/mozilla'
gmake[1]: *** [tier_toolkit] Error 2
gmake[1]: Leaving directory `/src/gnome/source/mozilla'
make: *** [default] Error 2
*** Error during phase build of mozilla: ########## Error running make
*** [74/238]

*******************************************************************************************************************************************
checking for LIBNOTIFY... yes
checking for UDISKS... configure: error: Package requirements (udisks
= 1.0.0 udisks < 1.1.0) were not met:

No package 'udisks' found
No package 'udisks' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables UDISKS_CFLAGS
and UDISKS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error during phase configure of gnome-disk-utility: ##########
Error running ./autogen.sh --prefix /src/gnome/install --libdir
'/src/gnome/install/lib64' --disable-static --disable-gtk-doc ***
[78/238]

*******************************************************************************************************************************************
checking pkg-config is at least version 0.9.0... yes
checking for DEVKIT... configure: error: Package requirements
(devkit-gobject >= 002) were not met:

No package 'devkit-gobject' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEVKIT_CFLAGS
and DEVKIT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error during phase configure of DeviceKit-power: ########## Error
running ./configure --prefix /src/gnome/install --libdir
'/src/gnome/install/lib64' --disable-static --disable-gtk-doc ***
[94/238]

*******************************************************************************************************************************************
make[4]: Entering directory
`/src/gnome/source/tracker-0.7.18/src/plugins/evolution'
make all-am
make[5]: Entering directory
`/src/gnome/source/tracker-0.7.18/src/plugins/evolution'
CC tracker-evolution-plugin.lo
tracker-evolution-plugin.c:211: error: expected ‘)’ before ‘*’ token
tracker-evolution-plugin.c:2161: error: expected ‘)’ before ‘*’ token
tracker-evolution-plugin.c: In function ‘tracker_evolution_plugin_init’:
tracker-evolution-plugin.c:2274: warning: passing argument 1 of
‘g_object_ref’ makes pointer from integer without a cast
/src/gnome/install/include/glib-2.0/gobject/gobject.h:441: note:
expected ‘gpointer’ but argument is of type ‘int’
make[5]: *** [tracker-evolution-plugin.lo] Error 1
make[5]: Leaving directory
`/src/gnome/source/tracker-0.7.18/src/plugins/evolution'
make[4]: *** [all] Error 2
make[4]: Leaving directory
`/src/gnome/source/tracker-0.7.18/src/plugins/evolution'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/src/gnome/source/tracker-0.7.18/src/plugins'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/src/gnome/source/tracker-0.7.18/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/src/gnome/source/tracker-0.7.18'
make: *** [all] Error 2
*** Error during phase build of tracker: ########## Error running make
*** [117/238]

*******************************************************************************************************************************************
checking for GLIB... yes
checking for boostlib >= 1.34... yes
checking whether the Boost::Signals library is available... yes
configure: error: Could not link against !
*** Error during phase configure of ekiga: ########## Error running
./autogen.sh --prefix /src/gnome/install --libdir
'/src/gnome/install/lib64' --disable-static --disable-gtk-doc ***
[133/238]

*******************************************************************************************************************************************
CC gtk-clutter-viewport.o
CC gtk-clutter-zoomable.o
LINK libclutter-gtk-0.10.la
/src/gnome/source/clutter-gtk-0.10.2/clutter-gtk/.libs/libclutter-gtk-0.10.so:
undefined reference to `GTK_WIDGET_REALIZED'
/src/gnome/source/clutter-gtk-0.10.2/clutter-gtk/.libs/libclutter-gtk-0.10.so:
undefined reference to `GTK_WIDGET_VISIBLE'
collect2: ld returned 1 exit status
Traceback (most recent call last):
File "/src/gnome/install/bin/g-ir-scanner", line 38, in <module>
sys.exit(scanner_main(sys.argv))
File "/src/gnome/install/lib64/gobject-introspection/giscanner/scannermain.py",
line 310, in scanner_main
glibtransformer.get_get_type_functions())
File "/src/gnome/install/lib64/gobject-introspection/giscanner/dumper.py",
line 226, in compile_introspection_binary
return dc.run()
File "/src/gnome/install/lib64/gobject-introspection/giscanner/dumper.py",
line 127, in run
self._link(bin_path, o_path)
File "/src/gnome/install/lib64/gobject-introspection/giscanner/dumper.py",
line 221, in _link
subprocess.check_call(args)
File "/usr/lib64/python2.6/subprocess.py", line 462, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['../libtool', '--mode=link',
'--tag=CC', '--silent', 'gcc', '-o',
'/src/gnome/source/clutter-gtk-0.10.2/clutter-gtk/tmp-introspect6jggyd/GtkClutter-0.10',
'-L.', '-lclutter-gtk-0.10', '-pthread', '-Wl,--export-dynamic',
'-L/src/gnome/install/lib64', '-lgio-2.0', '-lgirepository-1.0',
'-lgobject-2.0', '-lgmodule-2.0', '-lffi', '-lgthread-2.0', '-lrt',
'-lglib-2.0', '/src/gnome/source/clutter-gtk-0.10.2/clutter-gtk/tmp-introspect6jggyd/GtkClutter-0.10.o']'
returned non-zero exit status 1
make[2]: *** [GtkClutter-0.10.gir] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2
*** Error during phase build of clutter-gtk: ########## Error running
make *** [141/238]

*******************************************************************************************************************************************
CC epiphany-ephy-main.o
CCLD epiphany
../embed/.libs/libephyembed.a(libephyembed_la-ephy-web-view.o): In
function `ephy_web_view_clear_history':
/src/gnome/source/epiphany/embed/ephy-web-view.c:2200: undefined
reference to `webkit_web_back_forward_list_clear'
collect2: ld returned 1 exit status
make[4]: *** [epiphany] Error 1
make[4]: Leaving directory `/src/gnome/source/epiphany/src'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/src/gnome/source/epiphany/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/src/gnome/source/epiphany/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/src/gnome/source/epiphany'
make: *** [all] Error 2
*** Error during phase build of epiphany: ########## Error running
make *** [146/238]

*******************************************************************************************************************************************
CC nautilus-sendto-command.o
nautilus-sendto-command.c: In function ‘send_if_no_pack_cb’:
nautilus-sendto-command.c:338: warning: implicit declaration of
function ‘GTK_WIDGET_IS_SENSITIVE’
nautilus-sendto-command.c:338: warning: nested extern declaration of
‘GTK_WIDGET_IS_SENSITIVE’
CCLD nautilus-sendto
nautilus-sendto-command.o: In function `send_if_no_pack_cb':
/src/gnome/source/nautilus-sendto/src/nautilus-sendto-command.c:338:
undefined reference to `GTK_WIDGET_IS_SENSITIVE'
collect2: ld returned 1 exit status
make[3]: *** [nautilus-sendto] Error 1
make[3]: Leaving directory `/src/gnome/source/nautilus-sendto/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/src/gnome/source/nautilus-sendto/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/src/gnome/source/nautilus-sendto'
make: *** [all] Error 2
*** Error during phase build of nautilus-sendto: ########## Error
running make *** [171/238]

*******************************************************************************************************************************************
DEP addr.c
MAKE libnl.so.1.1
CC addr.c
In file included from addr.c:28:
../include/netlink-local.h: In function ‘__str2type’:
../include/netlink-local.h:218: error: ‘ULONG_MAX’ undeclared (first
use in this function)
../include/netlink-local.h:218: error: (Each undeclared identifier is
reported only once
../include/netlink-local.h:218: error: for each function it appears in.)
../include/netlink-local.h: In function ‘__list_str2type’:
../include/netlink-local.h:239: error: ‘ULONG_MAX’ undeclared (first
use in this function)
make[2]: *** [addr.o] Error 1
make[1]: *** [all] Error 2
make: *** [all] Error 2
*** Error during phase build of libnl: ########## Error running make
*** [182/238]

*******************************************************************************************************************************************
CC egg-dbus-monitor.o
CC gpk-enum.o
gpk-enum.c: In function ‘gpk_error_enum_to_localised_text’:
gpk-enum.c:521: error: ‘PK_ERROR_ENUM_ENUM_LAST’ undeclared (first use
in this function)
gpk-enum.c:521: error: (Each undeclared identifier is reported only once
gpk-enum.c:521: error: for each function it appears in.)
gpk-enum.c: In function ‘gpk_error_enum_to_localised_message’:
gpk-enum.c:760: error: ‘PK_ERROR_ENUM_ENUM_LAST’ undeclared (first use
in this function)
make[3]: *** [gpk-enum.o] Error 1
make[3]: Leaving directory `/src/gnome/source/gnome-packagekit/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/src/gnome/source/gnome-packagekit/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/src/gnome/source/gnome-packagekit'
make: *** [all] Error 2
*** Error during phase build of gnome-packagekit: ########## Error
running make *** [185/238]

*******************************************************************************************************************************************
checking pkg-config is at least version 0.9.0... yes
checking for GLIBMM... configure: error: Package requirements
(sigc++-2.0 >= 2.0 glib-2.0 >= 2.25.1 gobject-2.0 >= 2.25.1
gmodule-2.0 >= 2.25.1) were not met:

Requested 'glib-2.0 >= 2.25.1' but version of GLib is 2.24.1
Requested 'gobject-2.0 >= 2.25.1' but version of GObject is 2.24.1
Requested 'gmodule-2.0 >= 2.25.1' but version of GModule is 2.24.1

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GLIBMM_CFLAGS
and GLIBMM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error during phase configure of glibmm: ########## Error running
./autogen.sh --prefix /src/gnome/install --libdir
'/src/gnome/install/lib64' --disable-static --disable-gtk-doc ***
[190/238]

*******************************************************************************************************************************************
Running automake-1.11...
Makefile.am:25: GSETTINGS_SCHEMAS_INSTALL does not appear in AM_CONDITIONAL
Makefile.am:22: `gsettingsschema_DATA' is used but
`gsettingsschemadir' is undefined
*** Error during phase configure of gnome-system-tools: ##########
Error running ./autogen.sh --prefix /src/gnome/install --libdir
'/src/gnome/install/lib64' --disable-static --disable-gtk-doc ***
[197/238]

*******************************************************************************************************************************************
/bin/sh ../libtool --tag=CC --mode=link gcc -g -O2
-L/src/gnome/install/lib64 -o seahorse-daemon seahorse-daemon.o
seahorse-dbus-server.o seahorse-service.o seahorse-service-keyset.o
../libseahorse/libseahorse.la ../ssh/libseahorse-ssh.la
../common/libseahorse-common.la ../libcryptui/libcryptui.la
../libegg/libeggdatetime.la ../libegg/libeggsmclient.la
-Wl,--export-dynamic -pthread -L/src/gnome/install/lib64 -lgconf-2
-lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0
-lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype
-lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
-L/src/gnome/install/lib64 -lgnome-keyring -lglib-2.0 -pthread
-L/src/gnome/install/lib64 -ldbus-glib-1 -ldbus-1 -lpthread
-lgobject-2.0 -lgthread-2.0 -lrt -lglib-2.0 -pthread
-L/src/gnome/install/lib64 -lnotify -lgtk-x11-2.0 -ldbus-glib-1
-lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0
-lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig
-lgmodule-2.0 -ldbus-1 -lpthread -lgobject-2.0 -lgthread-2.0 -lrt
-lglib-2.0 -pthread -L/src/gnome/install/lib64 -lgcr -lgtk-x11-2.0
-ltasn1 -lgp11 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0
-lgdk_pixbuf-2.0 -lpangocairo-1.0 -lcairo -lpango-1.0 -lfreetype
-lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0
libtool: link: gcc -g -O2 -o .libs/seahorse-daemon seahorse-daemon.o
seahorse-dbus-server.o seahorse-service.o seahorse-service-keyset.o
-Wl,--export-dynamic -pthread -pthread -pthread -pthread
-L/src/gnome/install/lib64 ../libseahorse/.libs/libseahorse.a
../ssh/.libs/libseahorse-ssh.a
/src/gnome/source/seahorse/libcryptui/.libs/libcryptui.so
../common/.libs/libseahorse-common.a ../libcryptui/.libs/libcryptui.so
../libegg/.libs/libeggdatetime.a ../libegg/.libs/libeggsmclient.a -lSM
-lICE /src/gnome/install/lib64/libgconf-2.so
/src/gnome/install/lib64/libORBit-2.so
/src/gnome/install/lib64/libgnome-keyring.so
/src/gnome/install/lib64/libeggdbus-1.so
/src/gnome/install/lib64/libnotify.so
/src/gnome/install/lib64/libdbus-glib-1.so
/src/gnome/install/lib64/libdbus-1.so
/src/gnome/install/lib64/libgcr.so
/src/gnome/install/lib64/libgcrypt.so
/src/gnome/install/lib64/libgpg-error.so
/src/gnome/install/lib64/libgtk-x11-2.0.so
/src/gnome/install/lib64/libtasn1.so
/src/gnome/install/lib64/libgp11.so
/src/gnome/install/lib64/libgdk-x11-2.0.so
/src/gnome/install/lib64/libatk-1.0.so
/src/gnome/install/lib64/libgdk_pixbuf-2.0.so
/src/gnome/install/lib64/libgio-2.0.so -lresolv -lselinux
/src/gnome/install/lib64/libpangocairo-1.0.so
/src/gnome/install/lib64/libpangoft2-1.0.so
/src/gnome/install/lib64/libcairo.so
/src/gnome/install/lib64/libpixman-1.so -lpng12 -lXrender -lX11 -lz
/src/gnome/install/lib64/libpango-1.0.so -lm
/src/gnome/install/lib64/libfontconfig.so -lfreetype
/src/gnome/install/lib64/libexpat.so
/src/gnome/install/lib64/libgobject-2.0.so
/src/gnome/install/lib64/libgmodule-2.0.so -ldl
/src/gnome/install/lib64/libgthread-2.0.so -lpthread -lrt
/src/gnome/install/lib64/libglib-2.0.so -pthread -Wl,-rpath
-Wl,/src/gnome/install/lib64
seahorse-service.o: In function `seahorse_service_generate_credentials':
/src/gnome/source/seahorse/daemon/seahorse-service.c:217: undefined
reference to `seahorse_gpgme_generate_key'
collect2: ld returned 1 exit status
make[3]: *** [seahorse-daemon] Error 1
make[3]: Leaving directory `/src/gnome/source/seahorse/daemon'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/src/gnome/source/seahorse/daemon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/src/gnome/source/seahorse'
make: *** [all] Error 2
*** Error during phase build of seahorse: ########## Error running
make *** [1/33]

*******************************************************************************************************************************************
make[3]: Entering directory `/src/gnome/source/tomboy/Tomboy'
/src/gnome/install/bin/gmcs -debug -target:exe -out:Tomboy.exe -debug
-define:DEBUG -define:NET_2_0 -unsafe -target:exe -define:ENABLE_DBUS
-define:FIXED_PANELAPPLET -define:FIXED_GTKSPELL -define:HAS_GTK_2_16
Tomboy.cs Search.cs AbstractAddin.cs ActionManager.cs AddinManager.cs
AddinPreferenceFactory.cs ApplicationAddin.cs Contrast.cs Keybinder.cs
Logger.cs NativeApplication.cs Note.cs NoteAddin.cs NoteEditor.cs
NoteManager.cs NoteWindow.cs NoteBuffer.cs NoteRenameDialog.cs
NoteTag.cs PlatformFactory.cs Preferences.cs PreferencesClient.cs
PreferencesDialog.cs PreferenceTabAddin.cs PrefsKeybinder.cs
RecentChanges.cs RecentTreeView.cs Services.cs Tag.cs TagButton.cs
TagManager.cs Tray.cs Trie.cs Undo.cs Utils.cs Watchers.cs
Notebooks/CreateNotebookDialog.cs
Notebooks/NotebookApplicationAddin.cs Notebooks/Notebook.cs
Notebooks/NotebookManager.cs Notebooks/NotebookMenuItem.cs
Notebooks/NotebookNewNoteMenuItem.cs Notebooks/NotebookNoteAddin.cs
Notebooks/NotebooksTreeView.cs Synchronization/FileSystemSyncServer.cs
Synchronization/FuseSyncServiceAddin.cs Synchronization/ISyncUI.cs
Synchronization/SilentUI.cs Synchronization/SyncDialog.cs
Synchronization/SyncManager.cs Synchronization/SyncServiceAddin.cs
Synchronization/SyncUtils.cs Synchronization/TomboySyncClient.cs
Hyena/XdgBaseDirectorySpec.cs System.Web/HttpUtility.cs Applet.cs
GConfPreferencesClient.cs GnomeApplication.cs GnomeFactory.cs
XKeybinder.cs gtk-sharp-beans/Global.cs
gtk-sharp-beans/ImageMenuItem.cs Gnome.Keyring/AccessRights.cs
Gnome.Keyring/AttributeType.cs Gnome.Keyring/GenericItemData.cs
Gnome.Keyring/ItemACL.cs Gnome.Keyring/ItemData.cs
Gnome.Keyring/ItemType.cs Gnome.Keyring/KeyringException.cs
Gnome.Keyring/KeyringInfo.cs Gnome.Keyring/NetItemData.cs
Gnome.Keyring/NoteItemData.cs Gnome.Keyring/Operation.cs
Gnome.Keyring/RequestMessage.cs Gnome.Keyring/ResponseMessage.cs
Gnome.Keyring/ResultCode.cs Gnome.Keyring/Ring.cs IRemoteControl.cs
RemoteControl.cs RemoteControlProxy.cs Defines.cs
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/glib-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gnome-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/art-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gnome-vfs-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/glib-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gconf-sharp.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gtk-sharp-2.0/gconf-sharp-peditors.dll
-r:/src/gnome/install/lib64/pkgconfig/../../lib/mono/gnome-panel-sharp-2.24/gnome-panel-sharp.dll
-r:Mono.Posix
-r:/src/gnome/install/lib/mono/ndesk-dbus-1.0/NDesk.DBus.dll
-r:/src/gnome/install/lib/mono/ndesk-dbus-glib-1.0/NDesk.DBus.GLib.dll
-r:/src/gnome/install/lib64/mono/mono-addins/Mono.Addins.dll
-r:/src/gnome/install/lib64/mono/mono-addins/Mono.Addins.Gui.dll
-r:/src/gnome/install/lib64/mono/mono-addins/Mono.Addins.Setup.dll
-resource:../data/GNOME_TomboyApplet.xml,GNOME_TomboyApplet.xml
-resource:../data/UIManagerLayout.xml
-resource:../data/tomboy-note-clipboard-html.xsl,tomboy-note-clipboard-html.xsl
-resource:../data/icons/hicolor_apps_48x48_tomboy.png,tomboy.png
-resource:../data/icons/hicolor_places_22x22_note.png,note.png
-resource:../data/icons/hicolor_actions_16x16_note-new.png,note-new.png
-resource:../data/icons/hicolor_actions_22x22_filter-note-all.png,filter-note-all.png
-resource:../data/icons/hicolor_actions_22x22_filter-note-unfiled.png,filter-note-unfiled.png
-resource:../data/icons/hicolor_places_22x22_notebook.png,notebook.png
-resource:../data/icons/hicolor_actions_48x48_notebook-new.png,notebook-new.png
-resource:../data/icons/hicolor_status_16x16_pin-down.png,pin-down.png
-resource:../data/icons/hicolor_status_16x16_pin-up.png,pin-up.png
-resource:../data/icons/hicolor_status_16x16_pin-active.png,pin-active.png
-resource:./Tomboy.addin.xml
error CS0006: cannot find metadata file
`/src/gnome/install/lib64/mono/mono-addins/Mono.Addins.dll'
error CS0006: cannot find metadata file
`/src/gnome/install/lib64/mono/mono-addins/Mono.Addins.Gui.dll'
error CS0006: cannot find metadata file
`/src/gnome/install/lib64/mono/mono-addins/Mono.Addins.Setup.dll'
Compilation failed: 3 error(s), 0 warnings
make[3]: *** [Tomboy.exe] Error 1
make[3]: Leaving directory `/src/gnome/source/tomboy/Tomboy'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/src/gnome/source/tomboy/Tomboy'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/src/gnome/source/tomboy'
make: *** [all] Error 2
*** Error during phase build of tomboy: ########## Error running make
*** [216/238]

*******************************************************************************************************************************************
scripts/build-schemas.mk:7: `%'-style pattern rules are a GNU make extension
plugins/symbol-db/Makefile.am:84: `scripts/build-schemas.mk'
included from here
plugins/terminal/Makefile.am:17: `%'-style pattern rules are a GNU
make extension
plugins/terminal/Makefile.am:17: wildcard $(top_srcdir: non-POSIX variable name
plugins/terminal/Makefile.am:17: (probably a GNU make extension)
scripts/build-schemas.mk:7: `%'-style pattern rules are a GNU make extension
plugins/terminal/Makefile.am:47: `scripts/build-schemas.mk' included from here
plugins/tools/Makefile.am:18: `%'-style pattern rules are a GNU make extension
plugins/tools/Makefile.am:18: wildcard $(top_srcdir: non-POSIX variable name
plugins/tools/Makefile.am:18: (probably a GNU make extension)
scripts/build-schemas.mk:7: `%'-style pattern rules are a GNU make extension
src/Makefile.am:54: `scripts/build-schemas.mk' included from here
make: *** [Makefile.in] Error 1
*** Error during phase build of anjuta: ########## Error running make
*** [235/238]

*******************************************************************************************************************************************
*** module meta-gnome-devtools-suite not built due to non buildable
anjuta *** [237/238]
*** module meta-gnome-desktop not built due to non buildable
meta-gnome-desktop-suite *** [238/238]
*** module meta-gnome-desktop not built due to non buildable
meta-gnome-devtools-suite *** [238/238]
*** the following modules were not built *** [238/238]
mozilla gnome-disk-utility DeviceKit-power tracker ekiga clutter-gtk
epiphany nautilus-sendto gnome-bluetooth gnome-games libnl
NetworkManager gnome-packagekit gnome-power-manager gnome-session
glibmm pangomm gtkmm gnome-system-monitor gnome-system-tools
gnome-user-share seahorse seahorse-plugins tomboy yelp
meta-gnome-desktop-suite anjuta meta-gnome-devtools-suite
meta-gnome-desktop



--
Thanks,
Sam K. Raju
_______________________________________________
gnome-list mailing list
gnome-list@xxxxxxxxx
http://mail.gnome.org/mailman/listinfo/gnome-list



Relevant Pages

  • Re: configure
    ... The problem is the following error message: ... Package gtk+-2.0 was not found in the pkg-config search path. ... With these environment variables in effect, ...
    (comp.os.linux.misc)
  • xcb-util-image
    ... when we compile xcb-util-image its say that xcb-util is missing. ... Package xorg-macros was not found in the pkg-config search path. ... you may set the environment variables XCB_UTIL_CFLAGS ...
    (Debian-User)
  • Re: Updating Epiphany
    ... Since you are probably using the Gnome desktop, ... cd to the folder you unpacked the package to ... you may set the environment variables DEPENDENCIES_CFLAGS ... See the pkg-config man page for more details. ...
    (alt.os.linux.suse)
  • Package requirements (gtk+-2.0 >= 2.6.0) were not met
    ... i try to install ggobi on FC5 and got the ... No package 'gtk+-2.0' found ... you may set the environment variables GTK_CFLAGS ... and GTK_LIBS to avoid the need to call pkg-config. ...
    (Fedora)
  • Re: setting ./configure environmentals question
    ... it won't find gimp on my ... variables to avoid the need to call pkg-config. ... gimp-devel package includes the .pc files ... When I ran yum for the development package, it errored with needing gimp-libs, which starts with FC6 at the Freshmeat repo. ...
    (Fedora)