Re: [kde] Akonadi server will not start




Here is my problem. I keep getting error messages saying that there are old
akonadi server error logs. I deleted them and next time or next-next time I
get it again.

However, looking at these two files, I really don't know what the problem
would be. It was quite annoying. :(

Of course I just log out normally (with the lock/logout button) everyday I
finished my job in the office.

Any idea?

在 2010 年 05 月 20 日 週四 15:55:29,Kevin Krammer 寫道:
On Thursday, 2010-05-20, Jerry wrote:
I recently did a fresh install of KDE, Platform Version 4.4.3 (KDE
4.4.3), on FreeBSD-8/amd64 machine. Everything works except for the
akonadi server. It crashes as upon start-up. This is the error log.

Akonadi Server Self-Test Report
===============================

Test 1: SUCCESS
--------

Database driver found.
Details: The QtSQL driver 'QMYSQL' is required by your current Akonadi
server configuration and was found on your system.

File content of '/home/gerard/.config/akonadi/akonadiserverrc':
[%General]
Driver=QMYSQL
SizeThreshold=4096
ExternalPayload=false

[QMYSQL]
Name=akonadi
Host=localhost
User=xxxxxx
Password=XXXXXXXX
Options="UNIX_SOCKET=/home/gerard/.local/share/akonadi/db_misc/mysql.sock
et " ServerPath=/usr/local/bin/mysqld_safe
StartServer=false

Can you confirm that you are using a system wide MySQL server and have
configured it properly?

Test 12: ERROR
--------

Current Akonadi server error log found.
Details: The Akonadi server did report error during startup into <a
href='/home/gerard/.local/share/akonadi/akonadiserver.error'>/home/gerard
/. local/share/akonadi/akonadiserver.error</a>.

File content of '/home/gerard/.local/share/akonadi/akonadiserver.error':
"[
0: 0x414701 <_Z11akBacktracev+865> at /usr/local/kde4/bin/akonadiserver
1: 0x7fffffffffc4
]
"

The most common case for a backtrace in the log is database connection
failure or loss.
I have no personal experience with using a system wide MySQL daemon so I
won't be able to give you any hints on how to check that its setup is
correct.

Apparently, there is a problem with 'dbus' although I am not able to
figure out what. The resource agent message is also unclean. I am
hoping that someone can assist me here.

This is almost certainly just an effect of the problem Test 12 has found in
the log.
The Akonadi server process can't be found on the D-Bus session bus because
it shutdown or crashed, Test 6 just states what it sees and that is
Akonadi server not being registered at the bus.

Cheers,
Kevin

Attachment: akonadiserver.error.old
Description: application/trash

Attachment: akonadi_control.error.old
Description: application/trash

Attachment: signature.asc
Description: This is a digitally signed message part.

___________________________________________________
This message is from the kde mailing list.
Account management: https://mail.kde.org/mailman/listinfo/kde.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.

Relevant Pages

  • Re: [kde] Akonadi server will not start
    ... It crashes as upon start-up. ... Akonadi Server Self-Test Report ... Current Akonadi server error log found. ... Kevin Krammer, KDE developer, xdg-utils developer ...
    (KDE)
  • Re: [kde] Akonadi server will not start
    ... Akonadi Server Self-Test Report ... Akonadi server configuration and was found on your system. ... MySQL is started when I boot up. ... Current Akonadi server error log found. ...
    (KDE)