[kde-linux] Re: LCD weather widget not finding noaa stations



Duncan wrote:
Dale posted on Mon, 02 May 2011 05:26:42 -0500 as excerpted:


Does that belong to kdeplasma-addons? Google searches makes me think it
does. I thought about seeing if I can downgrade that one package and
see if it works again. Maybe if I configure it with the old package
that will do something.

I wasn't sure which files corresponded to that plasmoid, so I couldn't
equery files or belongs to see which package they corresponded to,
before. However, based on your pointer to kdeplasma-addons, it appears
you are correct, as

equery files kdeplasma-addons | grep weather

returns a number of weatherstation hits, with weatherstation matching the
name close enough that I'm pretty sure that's it.

Be aware that in ordered to downgrade, you'll probably need to feed
portage the --nodeps option, since otherwise it'll probably want to
downgrade a bunch of other kde-related stuff as well, because they keep
the versions pretty close to synced. But as long as you have the new
version installed, it should have the dependencies met, and within a minor/
feature series, thus within 4.6.x, versions should be pretty close to
compatible, no matter what portage thinks.

The problem would however be that due to the dependencies, you'll have
issues doing further world updates, or emerge --depcleans, etc, until you
get portage's deps straight once again.

What I did here with the one upgrade related bug I had, was first find and
confirm the individual package it was in, with a temporary downgrade test,
then, using the binpkgs (I run FEATURES=buildpkg for exactly this sort of
thing), upgraded once again and then switched out individual files from
the two versions until I knew which file it was in. Presently, therefore,
I'm upgraded to the new version (4.6.2), except that I have one file from
the 4.6.1 binpkg copied back over the 4.6.2 version. So the portage deps
work out fine (tho it would detect the one file as changed, but that
doesn't matter for deps calculation), and I can and have continued my
routine upgrades since, including revdep-rebuild (fortunately the two
files are close enough the binary deps are the same, tho that's expected
within the same kde minor) and emerge --depclean after every update, to
keep the system clean and free of cruft.



Well, I don't guess this will work. Ran into a slight problem:

root@fireball / # equery list -p kdeplasma-addons
[ Searching for package 'kdeplasma-addons' in all categories among: ]
* installed packages
[I--] [ ~] kde-base/kdeplasma-addons-4.6.2 (4.6)
* Portage tree (/usr/portage)
[-P-] [ ] kde-base/kdeplasma-addons-4.4.5 (4.4)
root@fireball / #

It appears that when 4.6.2 was added, they removed 4.6.1. I'll look to
see if I still have a binary tho. May unpack it and see what is
different first, if I have it still.

Dale

:-) :-)
___________________________________________________
This message is from the kde-linux mailing list.
Account management: https://mail.kde.org/mailman/listinfo/kde-linux.
Archives: http://lists.kde.org/.
More info: http://www.kde.org/faq.html.