Re: bonding - failed to get speed of NIC ?



William Reich a écrit :
I have a system setup with IP bonding.
The NIC cards are 1gig,
but sometimes, not always, I get this error ( below )
which makes the NICs into 100Mbps.
( observed on the RH 4 Update 4 system. )

Anybody know why ?

wr

++++++++


Aug 25 14:05:55 jazz kernel: bonding: Warning: failed to get
speed/duplex from eth3, speed forced to 100Mbps, duplex forced to Full.
Aug 25 14:05:55 jazz kernel: bonding: bond0: making interface eth3 the
new active one.
Aug 25 14:05:55 jazz kernel: bonding: bond0: enslaving eth3 as an active
interface with an up link.
...
Aug 25 14:05:55 jazz ifup: Enslaving eth4 to bond0
Aug 25 14:05:55 jazz kernel: bonding: Warning: failed to get
speed/duplex from eth4, speed forced to 100Mbps, duplex forced to Full.
Aug 25 14:05:55 jazz kernel: bonding: bond0: enslaving eth4 as a backup
interface with an up link.

On my server, the link speed cannot be detected at first but is set to 1000Mbps just after :

eth0: Broadcom NetXtreme II BCM5708 1000Base-SX (B2) PCI-X 64-bit 133MHz found at mem dc000000, IRQ 169, node addr 001e4f32f79e
eth1: Broadcom NetXtreme II BCM5708 1000Base-SX (B2) PCI-X 64-bit 133MHz found at mem da000000, IRQ 185, node addr 001e4f32f7a0

bonding: bond0: Warning: failed to get speed and duplex from eth0, assumed to be 100Mb/sec and Full.
bonding: bond0: enslaving eth0 as a backup interface with an up link.
ADDRCONF(NETDEV_CHANGE): bond0: link becomes ready
bnx2: eth0 NIC SerDes Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON

bonding: bond0: Adding slave eth1.
bnx2: eth1: using MSI
bonding: bond0: Warning: failed to get speed and duplex from eth1, assumed to be 100Mb/sec and Full.
bonding: bond0: making interface eth0 the new active one.
bonding: bond0: enslaving eth1 as a backup interface with an up link.
bnx2: eth1 NIC SerDes Link is Up, 1000 Mbps full duplex, receive & transmit flow control ON


--
Nicolas Cuissard

Université PARIS 1 - Panthéon Sorbonne
SIG - Service Informatique de Gestion
Tel : +33 (0)1 44 07 89 76
Fax : +33 (0)1 44 07 86 10

--
Ce message a ete verifie par MailScanner
pour des virus ou des polluriels et rien de
suspect n'a ete trouve.

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@xxxxxxxxxx?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list



Relevant Pages

  • Re: [v2 Patch 3/3] bonding: make bonding support netpoll
    ... # ifup bond0 bonding: bond0: setting mode to balance-rr. ... bonding: bond0: Setting MII monitoring interval to 1000. ... bnx2 0000:10:00.0: eth4: using MSIX bonding: bond0: enslaving eth4 as an active interface with a down link. ... # modprobe netconsole netconsole: local port 1234 ...
    (Linux-Kernel)
  • Re: sky2 and skge issue
    ... Recently we've been trying to set up 2 bonding interfaces with Intel ... bonding: bond0: enslaving eth0 as an active interface with a down link. ... bonding: bond0: enslaving eth1 as an active interface with a down link. ... bonding: bond1: setting mode to balance-rr. ...
    (Linux-Kernel)
  • Re: Sniffing split connections
    ... You could always use the linux kernels bonding feature. ... All traffic from eth1 and eth2 will be combined to a virtual interface ... device called bond0. ... > switch that connect to two different providers. ...
    (Focus-IDS)
  • [PATCH] bonding: select current active slave when enslaving device for mode tlb and alb
    ... bonding interface in mode balancing-alb. ... Then the current active slave is set to eth1 and link is working ... ADDRCONF: bond0: link is not ready ...
    (Linux-Kernel)
  • RHEL 3 ES; update 9; kernel 2.4.21-38.EL; bonding eth0/1 fails
    ... I have a HP DL380 with eth0 and eth1 on board. ... bond0 onto which a vlan is defined. ... After an update to update 9, the bond0 and bond0. ... so the interface itself seems to be ok. ...
    (linux.redhat)