RE: GCC package update/install



So, if I tried to update/upgrade cgg it tell me that it has a cpp dependency
Then I try to upgrade cpp and it tells me that it is available but not install,
Then I tried to install cpp and it tells me that it is installed.

Ay caramba! Help!

-----Original Message-----
From: redhat-list-bounces@xxxxxxxxxx [mailto:redhat-list-bounces@xxxxxxxxxx] On Behalf Of Florez, Nestor
Sent: Wednesday, June 01, 2011 9:12 AM
To: General Red Hat Linux discussion list
Subject: GCC package update/install

HI,

I am trying to upgrade gcc to gcc-4.1.2-46.el5_4.2.x86_64, but
it tells me that it has a dependencysee below:

[root@albacore ~]# yum install gcc-4.1.2-46.el5_4.2.x86_64
Loaded plugins: downloadonly, rhnplugin
Setting up Install Process
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-c++
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-gfortran
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-objc
--> Processing Dependency: gcc = 4.1.1-52.el5 for package: gcc-java
---> Package gcc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: cpp = 4.1.2-46.el5_4.2 for package: gcc
--> Processing Dependency: libgomp >= 4.1.2-46.el5_4.2 for package: gcc
--> Running transaction check
---> Package gcc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: cpp = 4.1.2-46.el5_4.2 for package: gcc
---> Package gcc-c++.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: libstdc++-devel = 4.1.2-46.el5_4.2 for package: gcc-c++
--> Processing Dependency: libstdc++ = 4.1.2-46.el5_4.2 for package: gcc-c++
---> Package gcc-gfortran.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: libgfortran = 4.1.2-46.el5_4.2 for package: gcc-gfortran
---> Package gcc-java.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: libgcj-devel = 4.1.2-46.el5_4.2 for package: gcc-java
--> Processing Dependency: libgcj = 4.1.2-46.el5_4.2 for package: gcc-java
---> Package gcc-objc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: libobjc = 4.1.2-46.el5_4.2 for package: gcc-objc
---> Package libgomp.x86_64 0:4.4.0-6.el5 set to be updated
--> Running transaction check
---> Package gcc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: cpp = 4.1.2-46.el5_4.2 for package: gcc
--> Processing Dependency: libgcj = 4.1.1-52.el5 for package: libgcj-src
---> Package libgcj.i386 0:4.1.2-46.el5_4.2 set to be updated
---> Package libgcj.x86_64 0:4.1.2-46.el5_4.2 set to be updated
---> Package libgcj-devel.i386 0:4.1.2-46.el5_4.2 set to be updated
---> Package libgcj-devel.x86_64 0:4.1.2-46.el5_4.2 set to be updated
---> Package libgfortran.x86_64 0:4.1.2-46.el5_4.2 set to be updated
---> Package libobjc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
---> Package libstdc++.i386 0:4.1.2-46.el5_4.2 set to be updated
---> Package libstdc++-devel.i386 0:4.1.2-46.el5_4.2 set to be updated
--> Running transaction check
---> Package gcc.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Processing Dependency: cpp = 4.1.2-46.el5_4.2 for package: gcc
---> Package libgcj-src.x86_64 0:4.1.2-46.el5_4.2 set to be updated
--> Finished Dependency Resolution
gcc-4.1.2-46.el5_4.2.x86_64 from rhel-x86_64-server-5 has depsolving problems
--> Missing Dependency: cpp = 4.1.2-46.el5_4.2 is needed by package gcc-4.1.2-46.el5_4.2.x86_64 (rhel-x86_64-server-5)
Error: Missing Dependency: cpp = 4.1.2-46.el5_4.2 is needed by package gcc-4.1.2-46.el5_4.2.x86_64 (rhel-x86_64-server-5)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles -nodigest
----------------------------------------------------

I ran package-cleanup but nothing was found
I tried upgrading and installing cpp-4.1.2-46.el5_4.2.x86_64 but it fails:
[root@albacore ~]# yum upgrade cpp-4.1.2-46.el5_4.2.x86_64
Loaded plugins: downloadonly, rhnplugin
Setting up Upgrade Process
Package(s) cpp-4.1.2-46.el5_4.2.x86_64 available, but not installed.
No Packages marked for Update
-------------------------------------
I tried installing cpp-4.1.2-46.el5_4.2.x86_64 but it fails:
[root@albacoreESC ~]# yum install cpp-4.1.2-46.el5_4.2.x86_64
Loaded plugins: downloadonly, rhnplugin
Setting up Install Process
Package matching cpp-4.1.2-46.el5_4.2.x86_64 already installed. Checking for update.
Nothing to do
---------------------------------------------------------

How can I upgrade gcc?

Thanks,

Néstor :)
--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@xxxxxxxxxx?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list

--
redhat-list mailing list
unsubscribe mailto:redhat-list-request@xxxxxxxxxx?subject=unsubscribe
https://www.redhat.com/mailman/listinfo/redhat-list