Re: [SLE] apt updates

From: Jerome Lyles (susemail_at_hawaii.rr.com)
Date: 08/31/04

  • Next message: Fareed Hussein: "[SLE] smary array 641 boot time loadable drivers"
    To: suse-linux-e@suse.com
    Date: Mon, 30 Aug 2004 23:36:04 -1000
    
    

    On Sunday 29 August 2004 11:16 am, Richard Bos wrote:
    > Op zondag 29 augustus 2004 23:09, schreef Jerome Lyles:
    > > OpenOffice_org OpenOffice_org Quickstarter OpenOffice_org-en
    >
    > > kdebindings3-javascript kdebindings3-perl kdebluetooth
    > >
    > > This list is much longer, but I'm tired of typing and I think you can see
    > > what's happening, apt seems to want to remove kde and some other stuff
    > > before it will upgradeing anything.  I think if I remove these packages I
    > > will be very, very sorry.:-)
    > >
    > > What should I do now?
    >
    > Find the reason why apt suggest this. Do this by upgrading 1 package at a
    > time (with the install action).
    >
    > In this case I prefer the command line, goto root:
    > > su -
    > > passwd:
    >
    > Hmmm, first are you more happy with the result of:
    > # apt dist-upgrade ???
    >
    > Other wise try:
    > # apt install digikam
    >
    > and
    >
    > # apt install OpenOffice_org
    >
    > --
    > Richard Bos
    > Without a home the journey is endless

    I didn't want to try apt dist-upgrade just yet but I did try apt install
    digikam:

    # apt install digikam
    Reading Package Lists... Done
    Building Dependency Tree... Done
    digikam is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
      kdebase3-devel: Depends: kdebase3 (= 3.2.3) but 3.2.1-68.15 is to be
    installed
      kdelibs3: Depends: arts (>= 1.2.3) but 1.2.1-35.4 is to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a
    solution).

    So is the reason that I have newer versions of dependency software than the
    update uses?
    Jerome

    -- 
    Check the headers for your unsubscription address
    For additional commands send e-mail to suse-linux-e-help@suse.com
    Also check the archives at http://lists.suse.com
    Please read the FAQs: suse-linux-e-faq@suse.com
    

  • Next message: Fareed Hussein: "[SLE] smary array 641 boot time loadable drivers"