[SLE] YaST Online Update Problem

From: Greg Wallace (jgregw_at_acsalaska.net)
Date: 09/05/04

  • Next message: Anders Johansson: "Re: [SLE] YaST Online Update Problem"
    To: <suse-linux-e@suse.com>
    Date: Sat, 4 Sep 2004 21:59:03 -0800
    
    

    I just migrated from SuSE Linux 8.1 Professional to 8.2 Professional (I'm
    moving toward 9.1 one version at a time). I didn't lose any data and
    everything seems to be functioning fine, with one notable exception. YaST
    Online Update no longer works! After I upgraded to 8.2, one of the first
    things I did was go to Online Update to pick up the latest updates to the
    particular packages in my installation. When I checked for updates, YaST
    returned a list of patches to 30 or 40 of my packages. I clicked the
    "Accept" button and YaST proceeded to "retrieve" all of the package updates.
    That part apparently worked fine, but when it went to the installation step,
    that step failed on every single one of the downloaded patches with the
    exact same error message -

    Error Installing patch '.' <-- Name of particular patch
      Skip this patch or abort the update?

    I would say to skip that one and then I would get the exact same message on
    the next one, and so on. At the end, I had had to skip every single one of
    them and the message at the end said "no packages have been installed". Has
    anyone else experienced this problem going from 8.1 to 8.2 (or on any other
    SuSE Linux upgrade)? I'm not familiar with the inner workings of RPM, but I
    would think this is some sort of RPM glitch (maybe due to a change to RPM
    itself going from 8.1 to 8.2). Any help greatly appreciated.

    Yours truly,
    Greg Wallace


  • Next message: Anders Johansson: "Re: [SLE] YaST Online Update Problem"

    Relevant Pages

    • Re: Impressions of Gentoo
      ... I'm thinking of giving Gentoo a try. ... for was 1) the kitchen-sink installation and 2) being rpm-based and the ... packages to have it install I ended up with a lot more stuff than I ... No rpm!! ...
      (comp.os.linux.misc)
    • Re: [opensuse] zypper, how to avoid rpm --force
      ... This means that it does not abort if 2 packages have conflicting ... In gerneral rpm doesn *not* respect the given order, ... I understand that it can't resolve these conflicts before downloading ... but I'd rather would like to see zypper aborting the installation after ...
      (SuSE)
    • Fwd: missing X11 when configuring mplayer
      ... The problem was Incompatible libXext in amd64 FC3 with mplayer. ... Do a YUM update with my FC3 installation, I got more than 300 packages ... all xorg-x11 amd64 rpm packages. ... YUM did an installation at the end with a completion station. ...
      (Fedora)
    • Re: [opensuse] Too much removed. Any help ?.
      ... using rpm commands (put in one line the rpm command with all the ... cd to the directory in the dvd holding the yast packages, ... yast2-installation>= 2.15.12 is needed by ... combination of the repair system and the installation system after ...
      (SuSE)
    • Re: yum vs. rpm to install occasional products
      ... coworker told me that I should use rpmbecause the installation ... Yellowdog Linux for the PowerPC) is an intelligent front end for rpm ... Dependency resolution is yum's. ... rpm can be used to remove packages without bitching about dependencies. ...
      (Fedora)