Re: [opensuse] rpm error[SOLVED]



On Friday 06 July 2007 04:14:19 Patrick Shanahan wrote:
* Susemail <susemail@xxxxxxxxxxxxx> [07-06-07 04:15]:
When I reference the rpm database I get an error message saying that
another process is using the database and that the package management
cannot be used now.

How can I get the PID of this mystery process so I can kill it?
Now I have to reboot to kill the prcess

from the cl: ps ax|grep rpm

or, just: killall rpm

--
Patrick Shanahan Plainfield, Indiana, USA HOG # US1244711
http://wahoo.no-ip.org Photo Album: http://wahoo.no-ip.org/gallery2
Registered Linux User #207535 @ http://counter.li.org

Thanks Patrick,

It worked. But not as I expected.
This is what I started with:

:~> ps ax|grep rpm
12442 pts/4 Ss+ 0:00
kdesu -n --nonewdcop -- /opt/kde3/share/apps/krpmview/setup_temp_source /home/myhome/bin/ekiga-2.0.9-0.pm.0.x86_64.rpm.part
12454 ? Ss
0:00 /bin/bash /opt/kde3/share/apps/krpmview/setup_temp_source /home/adriel/bin/ekiga-2.0.9-0.pm.0.x86_64.rpm.part
13971 ? S 0:00 /usr/bin/zypper service-delete _krpmview_temporary
8620 pts/10 S+ 0:00 grep rpm

So I decide to:
:~> killall rpm
rpm: no process killed

Then:
:~> ps ax|grep rpm
12442 pts/4 Ss+ 0:00
kdesu -n --nonewdcop -- /opt/kde3/share/apps/krpmview/setup_temp_source /home/adriel/bin/ekiga-2.0.9-0.pm.0.x86_64.rpm.part
12454 ? Ss
0:00 /bin/bash /opt/kde3/share/apps/krpmview/setup_temp_source /home/adriel/bin/ekiga-2.0.9-0.pm.0.x86_64.rpm.part
13971 ? S 0:00 /usr/bin/zypper service-delete _krpmview_temporary
8620 pts/10 S+ 0:00 grep rpm

So I decided to kill one process at a time. Killing the first one solved my
problem.

Why didn't killall rpm kill these processes?

Thanks,
Jerome




--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx