Re: [opensuse] KOTD source - strange rpm dependency failure



On Sat, May 10, Philipp Thomas wrote:
On Fri, 9 May 2008 19:57:41 -0400, Michael Fischer wrote:


FATAL: Could not load /lib/modules/2.6.22.5-31-default/modules.dep: No
such file or directory

modules.dep is created by running 'modprobe -a'

Thank you for the information.


(cd /user/src/linux...., make oldconfig, make dep didn't help)

Because its the wrong thing to do.

Thank you for the information.


Downloaded KOTD (2.6.25.2-2.1) rpm and got the following odd
failure on rpm -ivh

If you can't deal with such problems, I'd simply stay away from bleeding
edge kernels like KOTD.

No thank you for the condescension. Kind of hard to learn if you don't try
new things. Besides, I've been building kernels off and on for a few
years - usually when a CD distro kernel doesn't support my hardware.
Never had to look farther than the usual make menuconfig, make dep,
make, make modules, etc...

error: Failed dependencies:
rpmlib(PayloadIsLzma) <= 4.4.2-1 is needed by kernel-source-2.6.25.2-2.1.x86_64

Update rpm. We switched to compressing the rpm payload with lzma because
that yields noticeable better compression.

Thank you for the information.



Michael
--
Michael Fischer
michael@xxxxxxxx
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx