Re: [opensuse] Trying to make a wireless connection



A. den Oudsten wrote:
Ed Harrison schreef:
A. den Oudsten wrote:
Hans Krueger schreef:
A. den Oudsten wrote:
David C. Rankin wrote:

A. den Oudsten wrote:

I have an Acer Aspire 5315
I was able to connect my Atheros AR5006EG 802.11 b/g Wireless PCI Express Adapter to the Wifi source with the help of a driver net5211.inf I found on ftp://ftp.work.acer-euro.com/notebook/aspire_4710/driver/Wireless_Atheros.zip.

The Aspire 5351 went for repair of the DVD drive and when it came back there was the Atheros AR242x 802.11 abg Wireless PCI Express Adapter and what ever I tried with ndiswrapper and NDISGTK the driver net5211.inf was not accepted.
Any suggestion where and how I can get a proper driver?

Thanks in advance,

André den Oudsten


Links 2,3 & 5 from google "Atheros AR242 linux":

http://ubuntuforums.org/showthread.php?t=756318

http://ubuntu-utah.ubuntuforums.org/showthread.php?t=756318

http://www.uluga.ubuntuforums.org/showthread.php?t=756318&page=2

I haven't read them, but they look promising. I have also had the best luck with madwifi drivers from:

http://download.opensuse.org/repositories/home:/schmolle1980



Thanks for the suggestions, but they did not bring me to a solution.

Since then I tried to install with NDISGTK the following XP drivers from the Acer site:

netathr.inf; Invalid driver

netathrx.inf; Invalid driver

netw4k32.inf; Hardware present: No

netw4x32.inf; Invalid driver

netw4x64.inf; Hardware present: No

From 'hwinfo –netcard' I got:

Model: "Atheros AR242x 802.11abg Wireless PCI Express Adapter"

Driver Status: ath5k is active

Driver Activation Cmd: "modprobe ath5k"

Config Status: cfg=no, avail=yes, need=no, active=unknown

Attached to: #19 (PCI bridge)


From the madwifi site I learned that ath5k is the successor of madwifi.


What else can I do?

André den Oudsten

do what I did
http://snapshots.madwifi.org/special/madwifi-hal-0.10.5.6-r3698-20080604.tar.gz


You'll need to compile and install it, as described in README and
INSTALL files in the source code.

and uninstall the ath5k
good luck

I followed the instructions in First Time User HOWTO and after entering
make I got as reply:
bash: command not found

I was a little embarrassed!!

What can I do?

André

You need to install make and gcc. zypper -n in make gcc

Ed

I installed make and tried again.
After make I got:
Makefile.inc:91: *** KERNELCONF: /lib/modules/2.6.25.11-0.1-default/build/.config does not exist.. And indeed in /lib/modules/2.6.25.11-0.1-default/build/ I only found dumpfile.config and Module.symvers.
I'm one step further but I must say this matter is rather resistant!!!
Any suggestions?
André
is this your first time compiling ?

--

Hans Krueger
hanskrueger007@xxxxxxxxxxxxxx

registered Linux user 289023
411024








--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx