Re: [opensuse] Upgrading KDE4 on 11.1



On Wednesday 08 July 2009 19:33:33 Sven Burmeister wrote:
Am Mittwoch, 8. Juli 2009 19:57:16 schrieb Anton Aylward:
Indeed. So do I with that. I've never had "Dependency Hell" before,
and this blows me away.

It begins with this, an there are another 20 screenfuls that follow!
I've been keeping up to date with a daily "zypper up".

http://en.opensuse.org/KDE/KDE4#Most_Annoying_Bugs.2FTroubleshooting

Where's the clue fairy when you need her?


#### YaST2 conflicts list - generated 2009-07-08 13:50:36 ####

nothing provides libgps.so.17 needed by
kdebase4-workspace-4.2.95-282.3.i586

libgps is part of the DVD or oss repo which you seem to not have enabled.

Updating is possible, so any conflicts you get are resolveable if you add
the correct repos with the correct priorities. This is nothing about chiefs
or indians, just about settings up ones repos correctly and the knowledge
needed if one wants to use stuff that is not part of the DVD.

Sven

Sorry but I cannot accept that. I have reverted this box to 10.3 run the one
click KDE 4.3 and it worked with no problem at all

Surely the whole point of one click is that it offers you the repos required,
it certainly does with the nvidia drivers and the multimedia stuff which
surely takes care of the "setting up on'e repos correctly" point that you
make somewhat condescendingly if I may say so.

Whether you like it or not in my and others experience the upgrade of KDE4 on
11.1 is broken and that is simply not good enough. It should just work and
it doesn't.

Mike
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx