Re: [opensuse] rpmorphan package from Packman



On 01/12/2011 06:47 PM, John Andersen wrote:
On 1/11/2011 2:27 PM, Tejas Guruswamy wrote:


This is because rpmorphan only considers rpm "Requires:" and not
"Recommends:". So rpmorphan may consider packages orphaned which YaST2
considers needed.

Regards,
Tejas

Why would Yast treat recommends as required?

himm probably yast reads /etc/zypp/zypp.conf

##
## Whether required packages are installed ONLY
## So recommended packages, language packages and packages which depend
## on hardware (modalias) will not be regarded.
##
## Valid values: boolean
## Default value: false
##
solver.onlyRequires = false


Togan

--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse+help@xxxxxxxxxxxx



Relevant Pages

  • Re: KDE 4
    ... The following packages are BROKEN: ... Install the following packages: ... eyesapplet recommends kicker ... fifteenapplet recommends kicker ...
    (Debian-User)
  • KDE 4
    ... The following packages are BROKEN: ... Install the following packages: ... eyesapplet recommends kicker ... fifteenapplet recommends kicker ...
    (Debian-User)
  • Re: Problems Installing ia32-libs
    ... # aptitude upgrade ... Aptitude still wants to replace gnome etc with i386 packages. ... transcode recommends ...
    (Debian-User)
  • Re: insserv + apache2 + bind9 = pain
    ... a lot of unnecessary packages are now installed. ... Feel free to file bugs for every package which abuses Recommends. ... From what I understand, Debian started building upward. ... Debian installation was to install recommends by default as I remember. ...
    (Debian-User)
  • Re: Conflict resolution?
    ... I remember that Debian recommended aptitude and Ubuntu wanted apt. ... The following packages have unmet dependencies: ... speech-dispatcher recommends pulseaudio ...
    (Debian-User)