Re: [opensuse] Re: Problem? Solved? How to download i586/i686 packages needed for x86_64 system but not whole i586 distro?



On Sun, Apr 22, 2012 at 11:39 AM, Linda Walsh <suse@xxxxxxxxx> wrote:
Patrick Shanahan wrote:

* Linda Walsh <suse@xxxxxxxxx> [04-20-12 16:48]:

I was thinking about how to specify a list of packages to download  and
wanted
to be able to specify just updating/downloading the packages needed for
an
x86_64 system, without the requirement of downloading the entire
x586/x686
package set as well.

Currently, I don't see a way to do this -- since the packages in the
i[56]86
dirs needed for x86_64 seem to be mixed in with the i[58]86 distro --


Unless you have changed zypper configuration, it will do the sorting for
you, ie: do not specify architecture.

 zypper in --recommends samba-client

will examine your system and only download/install those packages matching
your system's architecture and requirements (and package suggestions re:
--recommends).

It will dl different packages for x86 and x86_64.




Um...

But I am trying to pre-download packages and then use that dir for a local
install dir.

zypper won't work if I don't populate the local install dir properly...



You can try zypper up --download-only

It will only fetch the packages but not install them, then you can
find the packages at /var/cache/zypp/packages
--
To unsubscribe, e-mail: opensuse+unsubscribe@xxxxxxxxxxxx
To contact the owner, e-mail: opensuse+owner@xxxxxxxxxxxx



Relevant Pages

  • Re: Low cost PCB layout software
    ... >could not get either release to install. ... I then tried to download 4.11 and ... Other packages installed ok, ... >Eagle Cadsoft Can't download or install ...
    (comp.arch.embedded)
  • Re: VM images for FreeBSD
    ... I'm working currently on creating images with a set pre-installed packages. ... I can't specify to pkg_add that it should treat /zpool0/testroot as root, ... unfortunately I can't specify some empty dir and install there). ... I downloaded all packages for 9-current i386, found all +INSTALL scripts, ...
    (freebsd-current)
  • Re: How to report bugs in Lucide?
    ... result, Odin is pretty much a dead product for me now, and will remain ... Acrobat5 requires the Innotek Runtime - an Odin build specific to this software - and is available on recent eCS install CDs. ... but I don't seem to be able to find a download url for rt112b20.exe as the urls found all point to the now defunct Innotek download website. ... You should be able to find either Zip or WPI packages available as alternatives to the yum/rpm packaged software - http://svn.netlabs.org/odin32 has the current odin for download as a zip file just below the yum/rpm promotion. ...
    (comp.os.os2.apps)
  • Re: knoppix HD-install problem
    ... I tried to install a package for the management of spatial data ... Knoppix packages too, and I was left with the sensation that not every ... I decided to be more scientific about my Debian download; ... message that the 2.4.27 version of the kernel I had been running so far ...
    (Debian-User)
  • Re: Where are packages cached localy on the machine that installs them?
    ... downloaded them, I cna NFS mount that location on other machines, and avoid ... them having to also download the same pacages before installing them. ... I assume that if I try to install a package, ... how can I share the lisy fo available packages thet is ...
    (Ubuntu)