Re: java JRE upgrade 10 does not work



On Tue, 23 Jan 2007 20:21:44 -0400
Derek Broughton <news@xxxxxxxxxxxxxx> wrote:

Peter Garrett wrote:
[snips]

after the java install ( not forgetting update-alternatives --config java
)

Not necessary - it's part of the install.

Really ? I didn't see it, and when I checked with update-alternatives
--config java I had to change the number...

- but I guess the method you used is just as easy
with auto-replace in your editor of choice. Personally I only wanted the
runtime and plugin so I installed sun-java6-bin and sun-java6-plugin

That's not a complete runtime - you need sun-java?-jre. The bin package is
just the native code. Damn, I forgot the plugin :-)

Umm...

$ apt-cache depends sun-java6-bin
sun-java6-bin
Depends: sun-java6-jre
[snip]

$ dpkg -l sun-java6-jre | grep ii
ii sun-java6-jre 6-00-2 Sun Java(TM) Runtime Environment (JRE) 6
(architecture independent files)


Caveat: this is safe enough with java, but not advisable for other
packages that might do something unpleasant, like try to change your libc6
version etc.

Yeah, I should probably have mentioned that... libc6 changes are annoying
enough _within_ a release (I've taken to removing libc6-i686 before any
upgrade that changes libc6, then reinstalling it - otherwise I routinely
find myself unable to run anything).

Right, libc6 needs careful handling - although I haven't had trouble
with it in upgrades here :)

Peter

--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users



Relevant Pages

  • Problem when migrating Debian 3.0 to 3.1
    ... i tried to migrate a server Debian installation from 3.0 to 3.1. ... while upgrading libc6. ... restarting sshd/telnetd should not affect any existing connections. ... If other services has begun to fail mysteriously after this upgrade, ...
    (Debian-User)
  • Re: afraid to upgrade libc6 and libc6-dev
    ... I just did an "aptitude update," and now when I attempt to upgrade, ... My question is "why are libc6 and libc6-dev being upgraded?" ...
    (Debian-User)
  • Re: Problem with upgrading libc6
    ... As long as I don't reboot the server, backing out of the problem is doable -- all I have to do is revert to the previous libc6, using: ... However, if a reboot is done, then that is a near-disaster condition -- libc6 is sufficiently deep in the system that it's pretty much impossible to resolve the conflict. ... Following a reboot, we made another try to resolve -- another attempt to upgrade libc6-dev failed, as did an attempt to downgrade libc6. ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx with a subject of "unsubscribe". ...
    (Debian-User)
  • chicken-and-egg upgrade problem sparc stable->testing
    ... I have sparc32 running debian stable and am trying to dist-upgrade ... to testing by following the provided upgrade doc that will be coming ... sparc32 stable running 2.2 kernel and old libc6 ...
    (Debian-User)
  • Help! FATAL: kernel too old
    ... I dusted off an old 2.0.x machine and decided to upgrade its ... Debian install. ... Anyway, the first thing I did was upgrade libc6, libstdc++ ... and apt to the woody versions because the old apt was ...
    (Debian-User)