Re: Package Installation (UPDATE)



I found a wiki page about this at:
https://help.ubuntu.com/community/EclipseWebTools

The author here says "...Ubuntu does come with many eclipse packages in
the universal repositories. Unfortunetly (or not) these all rely on the
GCJ compiler, and not the genuine Sun one. Many still prefer Sun's java
and this howto show how to use it."

Since I will be using Sun's SE 8.1 as part of my classes this semester,
would I be better off going according to these instructions instead of
the method I'm trying to use (outlined below) ?

Thanks for any input. I'd like to get this resolved and done with so I
can get on with using it...


On Wed, 2007-01-31 at 17:14 -0500, John Dangler wrote:
I looked up eclipse in the repo's, since I would like an IDE for Dapper
6.06 that I can do C, Java, and Python development in.

an initial look at sudo apt-get -s install eclipse, shows this:

The following extra packages will be installed:
ant ant-optional eclipse-jdt eclipse-jdt-common eclipse-pde
eclipse-pde-common eclipse-platform eclipse-platform-common eclipse-rcp
eclipse-rcp-common eclipse-source junit libbcel-java
libcommons-beanutils-java libcommons-collections-java
libcommons-collections3-java libcommons-dbcp-java
libcommons-digester-java libcommons-el-java libcommons-fileupload-java
libcommons-launcher-java libcommons-logging-java libcommons-modeler-java
libcommons-pool-java libgcj7-awt libjsch-java liblog4j1.2-java
liblucene-java liblucene-java-doc libmx4j-java libregexp-java
libservlet2.4-java libswt3.1-gtk-java libswt3.1-gtk-jni libtomcat5-java
mozilla-browser

Suggested packages:
ant-doc libbsf-java liboro-java jython antlr libjdepend-java
libgnumail-java libxml-commons-resolver1.1-java libcommons-net-java
javacc junit-doc libbcel-java-doc libcommons-beanutils-java-doc
libcommons-collections-java-doc libcommons-collections3-java-doc tomcat4
tomcat5 latex-xft-fonts

Recommended packages:
ecj-bootstrap ecj java-compiler eclipse-jdt-gcj eclipse-pde-gcj
eclipse-platform-gcj eclipse-rcp-gcj libswt3.1-gtk-gcj mozilla-psm

The following NEW packages will be installed:
ant ant-optional eclipse eclipse-jdt eclipse-jdt-common eclipse-pde
eclipse-pde-common eclipse-platform
eclipse-platform-common eclipse-rcp eclipse-rcp-common eclipse-source
junit libbcel-java
libcommons-beanutils-java libcommons-collections-java
libcommons-collections3-java libcommons-dbcp-java
libcommons-digester-java libcommons-el-java libcommons-fileupload-java
libcommons-launcher-java
libcommons-logging-java libcommons-modeler-java libcommons-pool-java
libgcj7-awt libjsch-java liblog4j1.2-java
liblucene-java liblucene-java-doc libmx4j-java libregexp-java
libservlet2.4-java libswt3.1-gtk-java
libswt3.1-gtk-jni libtomcat5-java mozilla-browser
0 upgraded, 37 newly installed, 0 to remove and 0 not upgraded.
Inst ant (1.6.5-3ubuntu1 Ubuntu:6.06/dapper)
Inst ant-optional (1.6.5-3ubuntu1 Ubuntu:6.06/dapper)
Inst eclipse-jdt-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst eclipse-platform-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst eclipse-rcp-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst libgcj7-awt (4.1.0-1ubuntu8 Ubuntu:6.06/dapper) []
Inst libswt3.1-gtk-jni (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst mozilla-browser (2:1.7.12-1.1ubuntu2 Ubuntu:6.06/dapper) []
Inst libswt3.1-gtk-java (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst eclipse-rcp (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst liblucene-java (1.4.3-9ubuntu2 Ubuntu:6.06/dapper) []
Inst liblucene-java-doc (1.4.3-9ubuntu2 Ubuntu:6.06/dapper) []
Inst libjsch-java (0.1.19-3ubuntu1 Ubuntu:6.06/dapper) []
Inst libservlet2.4-java (5.0.30-2ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-el-java (1.0-3 Ubuntu:6.06/dapper) []
Inst libregexp-java (1.4-1ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-collections3-java (3.1a-1ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-logging-java (1.0.4-3ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-beanutils-java (1.7.0-2ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-digester-java (1.7-1ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-fileupload-java (1.0-13 Ubuntu:6.06/dapper) []
Inst liblog4j1.2-java (1.2.12-1ubuntu2 Ubuntu:6.06/dapper) []
Inst libbcel-java (5.1-5ubuntu1 Ubuntu:6.06/dapper) []
Inst libmx4j-java (2.1.1-2 Ubuntu:6.06/dapper) []
Inst libcommons-modeler-java (1.1-7ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-collections-java (2.1.1-5 Ubuntu:6.06/dapper) []
Inst libcommons-pool-java (1.2-5 Ubuntu:6.06/dapper) []
Inst libcommons-dbcp-java (1.2.1-3ubuntu1 Ubuntu:6.06/dapper) []
Inst libcommons-launcher-java (1.1-3 Ubuntu:6.06/dapper) []
Inst libtomcat5-java (5.0.30-9 Ubuntu:6.06/dapper) []
Inst eclipse-platform (3.1.2-1ubuntu6 Ubuntu:6.06/dapper) []
Inst junit (3.8.1.1-5ubuntu1 Ubuntu:6.06/dapper) []
Inst eclipse-jdt (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Inst eclipse-pde-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Inst eclipse-pde (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Inst eclipse-source (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Inst eclipse (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf ant (1.6.5-3ubuntu1 Ubuntu:6.06/dapper)
Conf ant-optional (1.6.5-3ubuntu1 Ubuntu:6.06/dapper)
Conf eclipse-platform-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse-rcp-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf libgcj7-awt (4.1.0-1ubuntu8 Ubuntu:6.06/dapper)
Conf libswt3.1-gtk-jni (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf mozilla-browser (2:1.7.12-1.1ubuntu2 Ubuntu:6.06/dapper)
Conf libswt3.1-gtk-java (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse-rcp (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf liblucene-java (1.4.3-9ubuntu2 Ubuntu:6.06/dapper)
Conf liblucene-java-doc (1.4.3-9ubuntu2 Ubuntu:6.06/dapper)
Conf libjsch-java (0.1.19-3ubuntu1 Ubuntu:6.06/dapper)
Conf libservlet2.4-java (5.0.30-2ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-el-java (1.0-3 Ubuntu:6.06/dapper)
Conf libregexp-java (1.4-1ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-collections3-java (3.1a-1ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-logging-java (1.0.4-3ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-beanutils-java (1.7.0-2ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-digester-java (1.7-1ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-fileupload-java (1.0-13 Ubuntu:6.06/dapper)
Conf liblog4j1.2-java (1.2.12-1ubuntu2 Ubuntu:6.06/dapper)
Conf libbcel-java (5.1-5ubuntu1 Ubuntu:6.06/dapper)
Conf libmx4j-java (2.1.1-2 Ubuntu:6.06/dapper)
Conf libcommons-modeler-java (1.1-7ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-collections-java (2.1.1-5 Ubuntu:6.06/dapper)
Conf libcommons-pool-java (1.2-5 Ubuntu:6.06/dapper)
Conf libcommons-dbcp-java (1.2.1-3ubuntu1 Ubuntu:6.06/dapper)
Conf libcommons-launcher-java (1.1-3 Ubuntu:6.06/dapper)
Conf libtomcat5-java (5.0.30-9 Ubuntu:6.06/dapper)
Conf eclipse-platform (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf junit (3.8.1.1-5ubuntu1 Ubuntu:6.06/dapper)
Conf eclipse-jdt (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse-jdt-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse-pde-common (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse-pde (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse-source (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)
Conf eclipse (3.1.2-1ubuntu6 Ubuntu:6.06/dapper)

However, when I add the suggested packages to the install list, as in:
sudo apt-get -s install eclipse ant-doc libbsf-java liboro-java jython
antlr libjdepend-java libgnumail-java libxml-commons-resolver1.1-java
libcommons-net-java javacc junit-doc libbcel-java-doc
libcommons-beanutils-java-doc libcommons-collections-java-doc
libcommons-collections3-java-doc tomcat4 tomcat5 latex-xft-fonts

I get this -
Package jython is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or is
only available from another source.
E: Package jython has no installation candidate

Why would it get listed as a suggested package if it does not exist as
an installable package? (There are a couple of others that appear if I
remove jython from the list with the same error).

Should I just install eclipse alone and leave off the suggested and
recommended additional packages?





--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users