Re: g77-3.4, ubuntu 7.10



Hi

Thanks.
But please, see what I get:

dorita-laptop:~> sudo apt-get update && sudo apt-get install gfortran-4.2
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016) gutsy/main Translation-en_US
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016) gutsy/restricted Translation-en_US
Get:1 http://mirror.cricyt.edu.ar gutsy/ Release.gpg [189B]
Ign http://mirror.cricyt.edu.ar gutsy/ Translation-en_US
Hit http://mirror.cricyt.edu.ar gutsy/ Release
Ign http://mirror.cricyt.edu.ar gutsy/ Packages
Hit http://mirror.cricyt.edu.ar gutsy/ Packages
Fetched 1B in 4s (0B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package gfortran-4.2
dorita-laptop:~> sudo apt-get update && sudo apt-get install gfortran
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016) gutsy/main Translation-en_US
Ign cdrom://Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016) gutsy/restricted Translation-en_US
Get:1 http://mirror.cricyt.edu.ar gutsy/ Release.gpg [189B]
Ign http://mirror.cricyt.edu.ar gutsy/ Translation-en_US
Hit http://mirror.cricyt.edu.ar gutsy/ Release
Ign http://mirror.cricyt.edu.ar gutsy/ Packages
Hit http://mirror.cricyt.edu.ar gutsy/ Packages
Fetched 1B in 7s (0B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package gfortran is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package gfortran has no installation candidate

Dorita


Christian Stefanescu <st.chris@xxxxxxxxx> wrote: It seems to be on the repositories: http://packages.ubuntu.com/gutsy/devel/

sudo apt-get update && sudo apt-get install gfortran

or

sudo apt-get update && sudo apt-get install gfortran-4.2

should do it. (Execute one of the lines in italics in the console)

Regards,
Chris

On 11/2/07, Dorita Rostkier-Edelstein <drostkier@xxxxxxxxx> wrote: I see.

How should I install gfortran?

Thanks for your help.

Dorita


James Tappin < sjt@xxxxxxxxxxxxxxxxxx> wrote: On Fri, 2 Nov 2007 07:19:39 -0700 (PDT)
Dorita Rostkier-Edelstein wrote:

DRE> Hi
DRE>
DRE> I have done:
DRE>
DRE>
DRE> sudo apt-get install g77-3.4
DRE>
DRE> But when I try to compile this is what I get
DRE>
DRE> g77-3.4 test.f
DRE> /usr/bin/ld: crt1.o: No such file: No such file or directory
DRE> collect2: ld returned 1 exit status
DRE>
DRE> HELP!

Not a direct answer but:
g77 3.4 is pretty old (as seen by the fact that it pulls in gcc 3.4),
you might try using gfortran instead, as that is the fortran compiler
that goes with current versions of gcc.

James

--
+------------------------+-------------------------------+---------+
| James Tappin | School of Physics & Astronomy | O__ |
| sjt@xxxxxxxxxxxxxxxxxx | University of Birmingham | -- \/` |
| Ph: 0121-414-6462. Fax: 0121-414-3722 | |
+--------------------------------------------------------+---------+

--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users




=====================================
Dr. Dorita Rostkier-Edelstein, Ph.D.
Dept. of Applied Math., Env. Sci. Division
IIBR, Israel

Israel Meteorological Society Council Member

doritar@xxxxxxxxxxx
drostkier@xxxxxxxxx
=====================================


--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users



--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users



=====================================
Dr. Dorita Rostkier-Edelstein, Ph.D.
Dept. of Applied Math., Env. Sci. Division
IIBR, Israel

Israel Meteorological Society Council Member

doritar@xxxxxxxxxxx
drostkier@xxxxxxxxx
=====================================

--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users