Issue with upgrading from 8.10 -> 9.04



Hey,

I used Debian a couple of years ago and now want to use Linux again, this
time with Ubuntu. I went to 1und1 as a provider and rented a virtual server
that had 8.0.4 LTS on it. When I then tried to install git using a tutorial
on the ubuntu site I learned that the tutorial was based in 9.0.4 ;-(

I went to: https://help.ubuntu.com/community/UpgradeNotes and understood
that you can't do a direct upgrade but need to do this stepwise. I then did
the upgrade to 8.10 and that seemed to have worked, but when I then tried to
get to 9.0.4 I encountered this:


Processing triggers for libc6 ...
ldconfig deferred processing now taking place
(Reading database ... 18742 files and directories currently installed.)
Preparing to replace libc6 2.8~20080505-0ubuntu9 (using
.../libc6_2.9-4ubuntu6.1_amd64.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.15 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing
/var/cache/apt/archives/libc6_2.9-4ubuntu6.1_amd64.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.9-4ubuntu6.1_amd64.deb

Could not install the upgrades

The upgrade is now aborted. Your system could be in an unusable
state. A recovery will run now (dpkg --configure -a).

Please report this bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bug report.
E:Sub-process /usr/bin/dpkg returned an error code (1)

Setting up libgomp1 (4.3.3-5ubuntu4) ...

Processing triggers for libc6 ...
ldconfig deferred processing now taking place
/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API
not stable yet
warnings.warn("apt API not stable yet", FutureWarning)

Upgrade complete

The upgrade is completed but there were errors during the upgrade
process.


Could not install the upgrades

The upgrade is now aborted. Your system could be in an unusable
state. A recovery will run now (dpkg --configure -a).

Please report this bug against the 'update-manager' package and
include the files in /var/log/dist-upgrade/ in the bug report.
installArchives() failed

/usr/lib/python2.5/site-packages/apt/__init__.py:18: FutureWarning: apt API
not stable yet
warnings.warn("apt API not stable yet", FutureWarning)

Upgrade complete

The upgrade is completed but there were errors during the upgrade
process.


I *think* it says I should install a kernel manually (boy am I glad to be
back in Linux land)?


root@s15390688:~# apt-get install -t lenny linux-image-2.6
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package linux-image-2.6 is a virtual package provided by:
linux-image-2.6.28-18-virtual 2.6.28-18.59
linux-image-2.6.28-18-server 2.6.28-18.59
linux-image-2.6.28-18-generic 2.6.28-18.59
linux-image-2.6.28-17-virtual 2.6.28-17.58
linux-image-2.6.28-17-server 2.6.28-17.58
linux-image-2.6.28-17-generic 2.6.28-17.58
linux-image-2.6.28-16-virtual 2.6.28-16.57
linux-image-2.6.28-16-server 2.6.28-16.57
linux-image-2.6.28-16-generic 2.6.28-16.57
linux-image-2.6.28-15-virtual 2.6.28-15.52
linux-image-2.6.28-15-server 2.6.28-15.52
linux-image-2.6.28-15-generic 2.6.28-15.52
linux-image-2.6.28-14-virtual 2.6.28-14.47
linux-image-2.6.28-14-server 2.6.28-14.47
linux-image-2.6.28-14-generic 2.6.28-14.47
linux-image-2.6.28-13-virtual 2.6.28-13.45
linux-image-2.6.28-13-server 2.6.28-13.45
linux-image-2.6.28-13-generic 2.6.28-13.45
linux-image-2.6.28-3-rt 2.6.28-3.12
linux-image-2.6.28-11-virtual 2.6.28-11.42
linux-image-2.6.28-11-server 2.6.28-11.42
linux-image-2.6.28-11-generic 2.6.28-11.42
You should explicitly select one to install.
E: Package linux-image-2.6 has no installation candidate


How would I know which one to install? I know I am on a virtual server so I
tried this:



root@s15390688:~# apt-get install -t lenny linux-image-2.6.28-18-virtual
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
cpp-4.3: Depends: gcc-4.3-base (= 4.3.2-1ubuntu12) but 4.3.3-5ubuntu4 is
to be installed
libstdc++6: Depends: gcc-4.3-base (= 4.3.2-1ubuntu12) but 4.3.3-5ubuntu4
is to be installed
linux-image-2.6.28-18-virtual: Depends: initramfs-tools (>= 0.36ubuntu6)
but it is not going to be installed
Recommends: grub or
lilo (>= 19.1) but it is not
going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
a solution).
root@s15390688:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
cpp-4.3 libc6 libstdc++6
Suggested packages:
gcc-4.3-locales glibc-doc
The following packages will be upgraded:
cpp-4.3 libc6 libstdc++6
3 upgraded, 0 newly installed, 0 to remove and 200 not upgraded.
Need to get 0B/8680kB of archives.
After this operation, 365kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ... 18742 files and directories currently installed.)
Preparing to replace libc6 2.8~20080505-0ubuntu9 (using
.../libc6_2.9-4ubuntu6.1_amd64.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.15 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing
/var/cache/apt/archives/libc6_2.9-4ubuntu6.1_amd64.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.9-4ubuntu6.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@s15390688:~# apt-get install -t lenny linux-image-2.6.28-18-virtual
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
cpp-4.3: Depends: gcc-4.3-base (= 4.3.2-1ubuntu12) but 4.3.3-5ubuntu4 is
to be installed
libstdc++6: Depends: gcc-4.3-base (= 4.3.2-1ubuntu12) but 4.3.3-5ubuntu4
is to be installed
linux-image-2.6.28-18-virtual: Depends: initramfs-tools (>= 0.36ubuntu6)
but it is not going to be installed
Recommends: grub or
lilo (>= 19.1) but it is not
going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify
a solution).
root@s15390688:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
cpp-4.3 libc6 libstdc++6
Suggested packages:
gcc-4.3-locales glibc-doc
The following packages will be upgraded:
cpp-4.3 libc6 libstdc++6
3 upgraded, 0 newly installed, 0 to remove and 200 not upgraded.
Need to get 0B/8680kB of archives.
After this operation, 365kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
(Reading database ... 18742 files and directories currently installed.)
Preparing to replace libc6 2.8~20080505-0ubuntu9 (using
.../libc6_2.9-4ubuntu6.1_amd64.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.15 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing
/var/cache/apt/archives/libc6_2.9-4ubuntu6.1_amd64.deb (--unpack):
subprocess pre-installation script returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.9-4ubuntu6.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@s15390688:~#



Now I am sure this is an easy problem and all I need is in the output and it
should be expected to see something like that when upgrading ... But I
really don't understand what I should be doing here.

Could somebody please decipher this for me and give me step by step
instructions? If there are too many steps to write them up quickly, one step
at a time would certainly help me.

Cheers,
Mariano
--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users


Relevant Pages

  • unsubscribe
    ... > Subject: debian newbie... ... If I need to recompile the kernel, ... Also, what other additional packages, ... >> The package you're trying to install presumably ...
    (Debian-User)
  • libc6 kernel upgrade problem
    ... I am running debian unstable with kernel 2.6.5-1-k7 on an AMD Athlon ... When I try to upgrade the kernel it tells me: ... You might want to run `apt-get -f install' to correct these: ... The following packages have unmet dependencies: ...
    (Debian-User)
  • Re: [debian] problem with aptitude upgrade or dist-upgrade
    ... Definitely worth a kernel upgrade, ... The following NEW packages will be automatically installed: ... A package failed to install. ...
    (comp.os.linux.setup)
  • Re: [opensuse] Architecture switch 32->64 bit (i386 to x86-64)
    ... A "simple" upgrade with Yast from 10.3 installmedia leads to lots of dependency problems when resolving the packages. ... I wanted to get my kernel to 64-bits. ... One rpm line shows 55 rpm packages I had to install at same ...
    (SuSE)
  • SUSE Security Announcement: Linux Kernel (SuSE-SA:2004:001)
    ... installable through rpm, because of a bug in RPM (update of ... the kernel source is not ... sources that the binary kernel rpm packages are made from. ... are being offered to install from the maintenance web. ...
    (Bugtraq)