install openssh-client and fixing broken dependencies



I am using Ubuntu 12.04 Precise.
While installing package offline (no internet access), I ended up
installing old-version of openssh-client (1:4.7p1-8) by using dpkg. I
then got the following broken dependencies.

=======
ubuntu12.04LTS:~$ sudo apt-get check
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libssl1.0.0 : Breaks: openssh-client (< 1:5.9p1-4) but
1:4.7p1-8ubuntu1.2 is installed
openssh-client : Depends: libkrb53 (>= 1.6.dfsg.2) but it is not installable
Depends: libssl0.9.8 (>= 0.9.8g-4ubuntu3.1) but it
is not installable
E: Unmet dependencies. Try using -f.
=======


I downloaded correct version of openssh-client (1:5.9p1-5) and tested
reinstall with apt-get at follows.

=======
ubuntu12.04LTS:~$ sudo apt-get -o dir::caceh::archives=/home/myUbuntu
-f -s install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
openssh-client ssh-askpass-gnome ubuntu-desktop
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
1 not fully installed or removed.
Remv ubuntu-desktop [1.267] [openssh-client:amd64 libssl1.0.0:amd64 ]
Remv ssh-askpass-gnome [1:5.9p1-5ubuntu1] [openssh-client:amd64
libssl1.0.0:amd64 ]
Remv openssh-client [1:4.7p1-8ubuntu1.2]
=======

I am concerned whether this installation may cause further problem by
removing ubuntu-desktop which has multiple dependencies.

Do you have any idea how to safely install openssh-client with new
version without much trouble? I have attached current status of
dependent packages (ubuntu-desktop; ssh-askpass-gnome; libkrb53;
libssl1.0.0).

Thanks a lot.

_________
inhee park
ubuntu12.04LTS:~$ sudo apt-get check
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libssl1.0.0 : Breaks: openssh-client (< 1:5.9p1-4) but 1:4.7p1-8ubuntu1.2 is installed
openssh-client : Depends: libkrb53 (>= 1.6.dfsg.2) but it is not installable
Depends: libssl0.9.8 (>= 0.9.8g-4ubuntu3.1) but it is not installable
E: Unmet dependencies. Try using -f.



ubuntu12.04LTS:~$ sudo apt-get -o dir::caceh::archives=/home/myUbuntu -f -s install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
openssh-client ssh-askpass-gnome ubuntu-desktop
0 upgraded, 0 newly installed, 3 to remove and 0 not upgraded.
1 not fully installed or removed.
Remv ubuntu-desktop [1.267] [openssh-client:amd64 libssl1.0.0:amd64 ]
Remv ssh-askpass-gnome [1:5.9p1-5ubuntu1] [openssh-client:amd64 libssl1.0.0:amd64 ]
Remv openssh-client [1:4.7p1-8ubuntu1.2]



ubuntu12.04LTS:~$ dpkg -s libssl1.0.0
Package: libssl1.0.0
Status: install ok installed
Multi-Arch: same
Priority: required
Section: libs
Installed-Size: 2835
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@xxxxxxxxxxxxxxxx>
Architecture: amd64
Source: openssl
Version: 1.0.1-4ubuntu3
Depends: libc6 (>= 2.14), zlib1g (>= 1:1.1.4), debconf (>= 0.5) | debconf-2.0
Pre-Depends: multiarch-support
Breaks: openssh-client (<< 1:5.9p1-4), openssh-server (<< 1:5.9p1-4)




ubuntu12.04LTS:~$ dpkg -s libkrb5-3
Package: libkrb5-3
Status: install ok installed
Multi-Arch: same
Priority: standard
Section: libs
Installed-Size: 959
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@xxxxxxxxxxxxxxxx>
Architecture: amd64
Source: krb5
Version: 1.10+dfsg~beta1-2
Depends: libc6 (>= 2.14), libcomerr2 (>= 1.34), libk5crypto3 (>= 1.9+dfsg~beta1), libkeyutils1, libkrb5support0 (= 1.10+dfsg~beta1-2)
Pre-Depends: multiarch-support
Recommends: krb5-locales
Suggests: krb5-doc, krb5-user
Breaks: libsmbclient (<= 2:3.6.1-2), sssd (<= 1.2.1-4.3)
Conflicts: libkrb53


ubuntu12.04LTS:~$ dpkg -s openssh-client
Package: openssh-client
Status: purge ok unpacked
Priority: standard
Section: net
Installed-Size: 1900
Maintainer: Colin Watson <cjwatson@xxxxxxxxxx>
Architecture: amd64
Source: openssh
Version: 1:4.7p1-8ubuntu1.2
Config-Version: 1:5.9p1-5ubuntu1
Replaces: ssh, ssh-krb5
Provides: rsh-client, ssh-client
Depends: adduser (>= 3.10), debconf (>= 1.2.0) | debconf-2.0, dpkg (>= 1.7.0), libc6 (>= 2.4), libcomerr2 (>= 1.33-3), libedit2 (>= 2.5.cvs.20010821-1), libkrb53 (>= 1.6.dfsg.2), libncurses5 (>= 5.6+20071006-3), libssl0.9.8 (>= 0.9.8g-4ubuntu3.1), passwd, zlib1g (>= 1:1.2.3.3.dfsg-1)
Recommends: xauth
Suggests: keychain, libpam-ssh, ssh-askpass
Conflicts: rsh-client (<< 0.16.1-1), sftp, ssh (<< 1:3.8.1p1-9), ssh-krb5 (<< 1:4.3p2-7)
Conffiles:
/etc/ssh/ssh_config a7a6e6ef00bcd077b9b5e3e1b744fd30
/etc/ssh/moduli b1c007bf229d5d1707a2aebe9732f13c



ubuntu12.04LTS:~$ dpkg -s ubuntu-desktop
Package: ubuntu-desktop
Status: install ok installed
Priority: optional
Section: metapackages
Installed-Size: 57
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@xxxxxxxxxxxxxxxx>
Architecture: amd64
Source: ubuntu-meta
Version: 1.267

--
ubuntu-users mailing list
ubuntu-users@xxxxxxxxxxxxxxxx
Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users