Can't player DVDs with MPlayer

From: Blake Hutchinson (_nospam.tkdblake93_at_sbcglobal.net)
Date: 07/11/04


Date: Sun, 11 Jul 2004 16:27:26 GMT

I'm running SUSE 9.1 Professional. It's great with the exception of the
lack of support for DVD playback with the various video players:
Kaffeine, Noatun, Totem, Xine. I downloaded MPlayer and installed it.
When I run "mplayer dvd://1" from Konsole, I get the message below. How
do I fix it?

Thanks,
Blake

MPlayer 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Intel Pentium 4/Xeon/Celeron Foster 2692 MHz (Family: 8, Stepping: 9)
Detected cache-line size is 64 bytes
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2

Reading config file /usr/local/etc/mplayer/mplayer.conf: No such file or
directory
Reading config file /root/.mplayer/config
Reading /root/.mplayer/codecs.conf: 66 audio & 176 video codecs
font: can't open file: /root/.mplayer/font/font.desc
font: can't open file: /usr/local/share/mplayer/font/font.desc
Using Linux hardware RTC timing (1024Hz).
Input config file /root/.mplayer/input.conf parsed: 53 binds
Setting up LIRC support...
mplayer: could not connect to socket
mplayer: Connection refused
Failed to open LIRC support.
You will not be able to use your remote control.

Playing dvd://1.
Reading disc structure, please wait...
There are 2 titles on this DVD.
There are 3 chapters in this DVD title.
There are 1 angles in this DVD title.
DVD successfully opened.
MPEG-PS file format detected.
VIDEO: MPEG2 720x480 (aspect 2) 29.970 fps 3650.0 kbps (456.2 kbyte/s)
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
AC3: 2.0 (stereo) 48000 Hz 192.0 kbit/s
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, 16 bit (0x10), ratio: 24000->192000 (192.0 kbit)
Selected audio codec: [a52] afm:liba52 (AC3-liba52)
==========================================================================
vo: X11 running at 1024x768 with depth 16 and 16 bpp (":0.0" => local
display)
Disabling DPMS
==========================================================================
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
VDec: vo config request - 720 x 480 (preferred csp: Mpeg PES)
Could not find matching colorspace - retrying with -vf scale...
Opening video filter: [scale]
The selected video_out device is incompatible with this codec.
VDecoder init failed :(
Opening video decoder: [libmpeg2] MPEG 1/2 Video decoder libmpeg2-v0.3.1
Selected video codec: [mpeg12] vfm:libmpeg2 (MPEG 1 or 2 (libmpeg2))
==========================================================================
Checking audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
AF_pre: af format: 2 bps, 2 ch, 48000 hz, little endian signed int
AF_pre: 48000Hz 2ch Signed 16-bit (Little-Endian)
AO: [oss] 48000Hz 2ch Signed 16-bit (Little-Endian) (2 bps)
Building audio filter chain for 48000Hz/2ch/16bit -> 48000Hz/2ch/16bit...
Starting playback...
VDec: vo config request - 720 x 480 (preferred csp: Planar YV12)
VDec: using Planar YV12 as output csp (no 0)
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [xv] 720x480 => 720x540 Planar YV12
New_Face failed. Maybe the font path is wrong. 1 0% 0% 0.0% 0 0 0%
Please supply the text font file (~/.mplayer/subfont.ttf).
subtitle font: load_sub_face failed.
X11 error: BadAlloc (insufficient resources for operation)

MPlayer interrupted by signal 6 in module: flip_page
- MPlayer crashed. This shouldn't happen.
   It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
   gcc version. If you think it's MPlayer's fault, please read
   DOCS/HTML/en/bugreports.html and follow the instructions there. We
can't and
   won't help unless you provide this information when reporting a
possible bug.
Could not enable DPMS
Xlib: unexpected async reply (sequence 0x5e)!