weird xine/mplayer/lsdvd fail

From: Roeland Th. Jansen (bengel_at_grobbebol.xs4all.nl)
Date: 10/19/04


Date: Tue, 19 Oct 2004 08:03:41 +0000 (UTC)

hi all,

just wondering if someone has found a solution for the following
problem or has seen the same behaviour.

as known, suse comes with a non functional xine setup; you can easily
change that to a working variant by adding/changing a few rpms.

That works fine; up till..... some weeks ago when I bought a laptop. I
found that any instance of a region-coded dvd can't be seen anymore.

it all seems to boil down to the libdvdread function. There are several
hits for this how it cold be fixed but so far, nothing helped.
approaching the xine developers didn't give any answers (yet ?).

xine-check reports all [good]; mplayer also works fine with region-0
dvd's. both region 1 and 2 fail to play here, both under mplayer as well
as under xine. lsdvd also reports problems.

taplop:~ # lsdvd
libdvdread: Using libdvdcss version 1.2.8 for DVD access
libdvdread: Can't open file VIDEO_TS.IFO.
Can't open main ifo!

a different, non-region protected dvd:

taplop:~ # lsdvd
libdvdread: Using libdvdcss version 1.2.8 for DVD access
Disc Title: CSI_DISC_01
Title: 01, Length: 00:43:21 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 01
Title: 02, Length: 00:42:36 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 01
Title: 03, Length: 00:42:37 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 01
Title: 04, Length: 00:42:39 Chapters: 03, Cells: 03, Audio streams: 01, Subpictures: 01
Title: 05, Length: 00:02:01 Chapters: 01, Cells: 01, Audio streams: 01, Subpictures: 01
Title: 06, Length: 00:00:23 Chapters: 01, Cells: 01, Audio streams: 01, Subpictures: 01
Title: 07, Length: 00:00:27 Chapters: 01, Cells: 01, Audio streams: 01, Subpictures: 01
Title: 08, Length: 00:00:08 Chapters: 01, Cells: 01, Audio streams: 01, Subpictures: 01
Longest track: 1

and mplayer, xine will play this.

the weirdest part seems to be that if lsdvd the above DVD and then
try to play the region protected DVDs it works !

someone else also reported this behaviour, will see if I can find back
the URL that exactly describes this.

anyone suggestions ? it seems to be a libdvdread or libdvdcss problem
(latest available versions).

-- 
http://www.linux-it.nl


Relevant Pages

  • Burning a video DVD from VOB files (was: Re: copy DVD)
    ... a directory tree of a DVD is something like this: ... a standalone DVD player and in computer players (like mplayer or xine). ... This is xine - a free video player v0.99.3. ... libdvdread: Can't open file VIDEO_TS.IFO. ...
    (Debian-User)
  • Cant play video DVD
    ... After installing RH9 I tried Xine and was unable to see a film on DVD. ... libdvdread: Using libdvdcss version 1.2.7 for DVD access ... load_plugins: failed to load video output plugin ...
    (RedHat)
  • Re: [SLE] Inspiron sounds problems mostly solved, Except Xine with DVDs...help! UPDATE
    ... I finally got some sound out of Xine playing a DVD. ... > libdvdread: Using libdvdcss version 1.2.8 for DVD access ...
    (SuSE)
  • Re: [SLE] DVD Decrypter
    ... giving me help in copying a DVD movie. ... Up until today I had no problems playing DVD movies using xine. ... libdvdread: Could not open /dev/dvd with libdvdcss. ...
    (SuSE)
  • Re: DVD rippers under Linux
    ... DVD titles you have troubles with, ... $ lsdvd VIDEO_TS/ ... libdvdread: Couldn't find device name. ...
    (comp.os.linux.misc)