Re: ATI Driver & SuSe 10.1



Niel - When I try your suggestion I get the following:-

Creating directory fglrx-install
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux
Driver-8.24.8.............................................................
...........................................................................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: SuSE/SUSE101-IA32
Requested package is not supported.
Removing temporary directory: fglrx-install

Not sure if it has something to do with the Inspiron 9300 (Type of card) or
I'm missing some packages.

Niel Lambrechts wrote:

Bob & Gail wrote:
I have successfully upgraded 10.0 to 10.1 on my Dell Inspiron 9300 with
an ATI Video Controller (M300). The ati-driver-installer-8.24.8-x86.run
program appears to work but if I look
at /lib/modules/fglrx/build_mod/make.sh.log it complains, mainly about
firegl_public.c and ends with:-

make[4]: *** [/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Error 1
make[3]: *** [_module_/lib/modules/fglrx/build_mod/2.6.x] Error 2
make[2]: *** [modules] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.16.13-4-obj/i386/default'
make: *** [kmod_build] Error 2
build failed with return value 2

This worked fine under 10.0. It also will not allow me to use --buildpkg
to build an rpm file. Please advise if anyone can.

./ati-driver-installer-8.24.8-x86.run --buildpkg SuSE/SUSE101-IA32
and then
rpm -ivh fglrx_6_9_0_SUSE101-8.24.8-1.i386.rpm

worked for me on a brand-new SuSE 10.1 installation.

Regards,
Niel

.