No sound

From: Andrew O (ao314_at_hotmail.com)
Date: 09/22/04


Date: 22 Sep 2004 07:24:53 -0700

Having raked through the internet, I know this is a topic already
covered a lot - but I'm still getting to grips with Linux. My nforce
420 sound card does not work. I've tried Sound Card detection (under
Gnome), upgrading to kernel 2.6.8, installing alsa drivers/lib/utils
1.0.6, running alsa conf and adding i810_audio to
/etc/hotplug/blacklist. I'm using Fedora Core 2 with a 2.6.5 kernel,
for some reason or another the 2.6.8 kernel keeps hanging after login.
Sound used to work sporadically under mandrake 8.1 - sometimes it
worked sometimes it didn't. I got sound to work under Fedora 2 at one
stage, but turned off my computer and when I turned it back on again
it was once again mute.

In current state of my computer:
Running alsaconf, following the onscreen instructions I get

Loading driver...
Starting sound driver: snd-intel8x0 done
/usr/sbin/alsactl: load_state:1134: No soundcards found...
Setting default volumes...
===============================================================================

 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

/sbin/lsmod | grep "snd"
snd_pcm_oss 46376 0
snd_mixer_oss 17024 1 snd_pcm_oss
snd_intel8x0 31180 0
snd_ac97_codec 59600 1 snd_intel8x0
snd_pcm 73096 2 snd_pcm_oss,snd_intel8x0
snd_timer 20740 1 snd_pcm
gameport 3328 1 snd_intel8x0
snd_mpu401_uart 6784 1 snd_intel8x0
snd_rawmidi 20772 1 snd_mpu401_uart
snd_seq_device 7816 1 snd_rawmidi
snd 45316 9
snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore 6112 1 snd
snd_page_alloc 9352 2 snd_intel8x0,snd_pcm

 more modprobe.conf
alias eth0 forcedeth
# alias snd-card-0 snd-intel8x0
# install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 &&
/usr/sbin/alsactl restore >/dev/null 2>&1 || :
# remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ;
}; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ohci-hcd
 
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF verion 1.0.6 ---
alias snd-card-0 snd-intel8x0
alias sound-slot-0 snd-intel8x0
# --- END: Generated by ALSACONF, do not edit. ---

Also, booting to linux then restarting to windows gives windows
problems with the network.

Regards
Andrew



Relevant Pages

  • Re: Sound - handmade how?
    ... What is the format I can send to the sound card? ... I wrote an audio recorder and audio player based on the Open Sound System ... OSS is effectively dead on Linux. ... The OSS emulation from ALSA was ...
    (Debian-User)
  • Re: Is it time for remove (crap) ALSA from kernel tree ?
    ... So this source without problems code can be integragrated in Linus tree and after this Linux can provide much better soud supoport than with current ALSA. ... I know this may sound kind of stupid, but how about not deprecating either, and fully supporting both sound systems? ...
    (Linux-Kernel)
  • Re: F11 fix for sound on Intel HDA machines ?
    ... I pulled the 1.0.20 alsa RPMs out of testing and rebooted. ... there is mention of the chip in the code in relation to asus-p5q. ... I found this overview of sound in Linux: ...
    (Fedora)
  • Re: Sound has stopped working... (solved)
    ... Latest kde upgrade changed default sound to alsa and I've had to use ... > Linux: usuari registrat 190.783 ...
    (Debian-User)
  • Re: WARNING to potential LINUX users
    ... And I did not ask specificly for linux supported hardware, ... IDE CD-ROMS or DVD drives all ... > the sound events were turned on and the mixer showed volume was maximum ...
    (alt.os.linux.suse)