Re: SuSE 8.2 kdm vs RH 9 kdm -- XDMCP

From: Andrew DeFaria (Andrew_at_DeFaria.com)
Date: 12/18/03


Date: Thu, 18 Dec 2003 14:57:13 -0800

Dave Brown wrote:

> In article <HLtsD4.CCt@ozemail.com.au>, Jack Strangio wrote:
>
>> jvstrangio@ozemail.com.au (Jack Strangio) writes:
>>
>>> Dave Brown <dhbrown@hobbes.dhbrown.net> writes:
>>>
>>>> I was experimenting with a pc_Xstation, and tried to attach to a
>>>> SuSE 8.2 system and get a login screen. The 'Xaccess' file seems
>>>> okay ("* #any host can get a login window"), and the 'kdmrc' file
>>>> was fixed to "[Xdmcp] Enable=true". But, no joy. I had no trouble
>>>> attaching to the same machine when I booted RH 9. (No firewall in
>>>> either case.)
>>>
>>> Is xdm running on the SuSe machine?
>>
>> Sorry, I forgot to say have you changed your xdm-config file also?
>>
>> add a '!' to the 'requestPort' line as below:
>>
>> ! SECURITY: do not listen for XDMCP or Chooser requests
>> ! Comment out this line if you want to manage X terminals with xdm
>> !DisplayManager.requestPort: 0
>
> Yes, I'd "fixed" that also.

Was there any final resolution for this because I have a similar problem
with SuSE 8.2 and using Cygwin/XFree86. I've been pulling my hair out
over this for a few days now. Don't understand what is wrong, the X
server starts but no chooser or any other application starts.

-- 
When something is "new and improved!". Which is it? If it's new, then 
there has never been anything before it. If it's an improvement, then 
there must have been something before it.