Re: Installing BitTorrent-4.20.4 - weird problem




Unruh napisal(a):
opexoc@xxxxxxxxx writes:

Hi. I am trying to install BitTorrent-4.20.4 from sources, but I come
to a standstill. I read in some information file in BitTorrent sources
directory how to install BitTorrent using Python:

How to install BitTorrent using Python's distutils system:
----------------------------------------
Install BitTorrent by running this from the root of the source code
directory:

$ python setup.py install

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
, so I do everything in this way and I get:


--------------------------------------------------------CUT
HERE-------------------------------------------------------------------
[root@localhost BitTorrent-4.20.4]# python setup.py install
running install
error: invalid Python installation: unable to open
/usr/lib/python2.4/config/Makefile (No such file or directory)
--------------------------------------------------------CUT
HERE-------------------------------------------------------------------


Sounds to me like you forgot to install the libpython2.4-devel package.
You do not say which distro you run, but look for a libpython2.4-devel rpm
and install that.

Also when you ask questions about a linux distro, tell us which distro you
have, as different Linux distros do things differently.

btw2. For what is using this libpython2.4-devel package ? Am I not able
to compile files without it ?
Moreover, what does it mean string "devel" ending some names of
packages ( develope ? ) ?

.



Relevant Pages

  • Re: Whats so funny? WAS Re: rotor replacement
    ... That I have to download and perhaps install them to use ... > * I have to download and build the MySQLdb package to talk to MySQL ... > servers from Python code ... I can write something using a core module instead of an external ...
    (comp.lang.python)
  • RE: Python 2.4 killing commercial Windows Python development ?
    ... > install fully useable Python on their Windows machines. ... > Quicksomething for Windows, or RealPlayer, ... The Windows application that I develop and distribute relies on Python ...
    (comp.lang.python)
  • Re: bytecode non-backcompatibility
    ... Unstable bytecodes makes updating to a newer version of Python very ... >>>tedious and risk breaking old scripts, ... > setup.py install" to install the library into site-package. ... each port has a list of all the other ports it depends ...
    (comp.lang.python)
  • HOWTO: Python 2.3 on Fedora Core 1 Linux
    ... About the 'new' Python ... Appendix A: Python Installation with Tkinter - edit: Modules/Setup.dist ... Be aware that it is always risky to install new software; ... # uncomment and/or edit those parts as indicated. ...
    (comp.lang.python)
  • Re: Python 2.4 killing commercial Windows Python development ?
    ... install fully useable Python on their Windows machines. ... different to me than having to install Shockwave, ... Quicksomething for Windows, or RealPlayer, ... The Windows application that I develop and distribute relies on Python ...
    (comp.lang.python)