Can't get WiFi to work



I just installed Suse 10.0 as dual-boot with Win/2000 on an IBM Thinkpad
T23. I am trying to use a Linksys WPC11 v4 pcmcia. Under Win/2000, it
works perfectly (same machine, same AP, same WEP encryption, etc.)

When I try to use it under Suse, then try to ping www.yahoo.com, I get "unknown host www.yahoo.com". If I ping local addesses on my home network, i get "network is unreachable". (127.0.0.1 pings just fine, thank-you). If I try to browse, I get www.cnn.com could not be found.

If I plug in an ethernet cable, all network activity is normal.

Following are some settings that I think might be informative. If
anybody else has something else I should try, I would be grateful.

Thanks in advance for any suggestions

73 de Jim

===
This is the pertinent part of my iwconfig list.

wlan1 IEEE 802.11b ESSID:"FN31gl"
Mode:Managed Frequency:2.432 GHz Access Point:
00:00:00:00:00:00
Bit Rate=11 Mb/s
Retry:on Fragment thr:off
Encryption key:79AC-7C21-B7B9-6C58-A95E-xxxx-xx Security
mode:restricted
Link Quality=28/100 Signal level=-31 dBm Noise level=-184 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0



This is the start portion of /etc/init.d/network restart (note the
ethernet cable is unplugged)
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
eth0 device: Intel Corporation 82801CAM (ICH3) PRO/100 VE
(LOM) Ethernet Controller (rev 42)
eth0 configuration: eth-id-00:d0:59:ca:a0:8a
eth0 (DHCP) . . . . . no IP address yet... backgrounding.
waiting
wlan0 device: Intersil Corporation Prism 2.5 Wavelan chipset
(rev 01)
wlan0 No configuration found for wlan0
unused
wlan1 device: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b
MAC (rev 20)
wlan1 configuration: wlan-bus-pcmcia
ifup-wireless: command 'iwconfig wlan1 nick (none)' returned
ifup-wireless: Error for wireless request "Set Nickname" (8B1C) :
ifup-wireless: SET failed on device wlan1 ; Operation not permitted.
wlan1 (DHCP) . . . . . no IP address yet... backgrounding.
waiting
Setting up service network . . . . . . . . . . . . . . done
SuSEfirewall2: Warning: ip6tables does not support state matching.
Extended IPv6 support disabled.
SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
SuSEfirewall2: batch committing...
SuSEfirewall2: Firewall rules successfully set
(none):~ #
.