Re: VNC viewer is connected but blank screen



On Mon, 24 Mar 2008 13:35:46 -0700, Salih wrote:

I was able to run a vncserver and connect to it without a problem. After
switching to xfce from kde, viewer connects but all I get is a blank
screen with mouse working.

I am running the server on a Kubuntu machine. I tried connecting to it
via TightVNC from a Windows machine as well as via vncviewer to
localhost from the Linux server itself.

When I run the server I get the following log:

4/03/08 13:32:12 Xvnc version 3.3.7 - built May 24 2007 12:47:11
24/03/08 13:32:12 Copyright (C) 2002-2003 RealVNC Ltd. 24/03/08 13:32:12
Copyright (C) 1994-2000 AT&T Laboratories Cambridge. 24/03/08 13:32:12
All Rights Reserved. 24/03/08 13:32:12 See http://www.realvnc.com for
information on VNC 24/03/08 13:32:12 Desktop name 'X' (cellular:1)
24/03/08 13:32:12 Protocol version supported 3.3 24/03/08 13:32:12
Listening for VNC connections on TCP port 5901

When I connect from the client using vncviewer, this additional message
is received:

24/03/08 13:32:53 Got connection from client 0.0.0.0 24/03/08 13:32:53
Protocol version 3.3 24/03/08 13:32:55 Pixel format for client 0.0.0.0:
24/03/08 13:32:55 8 bpp, depth 6
24/03/08 13:32:55 true colour: max r 3 g 3 b 3, shift r 4 g 2 b 0
24/03/08 13:32:55 rfbProcessClientNormalMessage: ignoring unknown
encoding type -239
24/03/08 13:32:55 rfbProcessClientNormalMessage: ignoring unknown
encoding type -223
24/03/08 13:32:55 Using ZRLE encoding for client 0.0.0.0

I don't know how to debug it and logs do not tell much. Does anybody
have any idea what would be the cause?

Thanks...

sounds like your not starting a xfce session manager if you want to run
xfce. Do you have:

/usr/bin/xfce4-session
in your xstartup and does
ps -aef | grep xfce
show some xfce processes running after you start your vncserver?

jack

.



Relevant Pages

  • Re: yum package cleanup
    ... I then used createrepo to create my own local RPM repo so that my other Fedora machines connect to it rather than the internet. ... Server and on which system you're getting the error message. ... Until a couple of days ago, XFCE was working just fine. ... One set of panels is that of Gnome - on top is the launch bar, ...
    (Fedora)
  • Re: xdm login infinite loop
    ... returns me to the login display. ... I'm using xfce and xdm on a thinkpad i series ... on X server:0.0. ... To UNSUBSCRIBE, email to debian-user-REQUEST@xxxxxxxxxxxxxxxx ...
    (Debian-User)
  • Re: FreeBSD on lame hardware?
    ... Lee Harr wrote: ... >> XFCE is great. ... >> As a server for static and light dynamic webpages it should do, ...
    (comp.unix.bsd.freebsd.misc)
  • Re: How do I shadow my console with vnc-server?
    ... How do I shadow my console with vnc-server? ... a virtual machine on my server, ... an Xfce 4.4.2 GUI is crashed and I need to restart it. ...
    (comp.os.linux.misc)
  • VNC viewer is connected but blank screen
    ... I am running the server on a Kubuntu machine. ... When I connect from the client using vncviewer, ... encoding type -239 ...
    (comp.os.linux.networking)